<!DOCTYPE html>
<!--[if IEMobile 7]><html class="iem7"  lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="lt-ie9 lt-ie8 lt-ie7"  lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="lt-ie9 lt-ie8"  lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="lt-ie9"  lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><!--><html  lang="en" dir="ltr" prefix="og: http://ogp.me/ns#"><!--<![endif]-->

<head>
  <!--[if IE]><![endif]-->
<meta charset="utf-8" />
<link rel="shortcut icon" href="https://www.autocar.co.uk/sites/autocar.co.uk/themes/custom/autocar/favicon.ico" type="image/vnd.microsoft.icon" />
<script type="application/ld+json">{
    "@context": "https://schema.org/",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "name": "Car news",
                "@id": "https://www.autocar.co.uk/car-news"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "name": "Features",
                "@id": "https://www.autocar.co.uk/topics/features"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "name": "Ford Mustang versus Chevrolet Camaro: muscle car twin test",
                "@id": "https://www.autocar.co.uk/car-news/features/ford-mustang-versus-chevrolet-camaro-muscle-car-twin-test"
            }
        }
    ]
}</script>
<script type="application/ld+json">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</script>
<meta name="description" content="We compare two brawny, V8-engined old-school muscle cars, to see which best suits a UK buyer" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.autocar.co.uk/car-news/features/ford-mustang-versus-chevrolet-camaro-muscle-car-twin-test" />
<link rel="shortlink" href="https://www.autocar.co.uk/node/85349" />
<meta property="og:type" content="article" />
<meta property="og:site_name" content="Autocar" />
<meta property="og:url" content="https://www.autocar.co.uk/car-news/features/ford-mustang-versus-chevrolet-camaro-muscle-car-twin-test" />
<meta property="og:title" content="Ford Mustang versus Chevrolet Camaro: muscle car twin test | Autocar" />
<meta property="og:description" content="We compare two brawny, V8-engined old-school muscle cars, to see which best suits a UK buyer" />
<meta property="og:image" content="https://www.autocar.co.uk/sites/autocar.co.uk/files/images/car-reviews/first-drives/legacy/mustang-camaro-2761.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@autocar" />
<meta name="twitter:url" content="https://www.autocar.co.uk/car-news/features/ford-mustang-versus-chevrolet-camaro-muscle-car-twin-test" />
<meta name="twitter:title" content="Ford Mustang versus Chevrolet Camaro: muscle car twin test" />
<meta name="twitter:description" content="We compare two brawny, V8-engined old-school muscle cars, to see which best suits a UK buyer" />
<meta name="twitter:image" content="https://www.autocar.co.uk/sites/autocar.co.uk/files/images/car-reviews/first-drives/legacy/mustang-camaro-2761.jpg" />
<script>
    window._sp_ = window._sp_ || {};
    window._sp_.config = window._sp_.config || {};
    window._sp_.config.account_id = 1048;
    window._sp_.config.content_control_callback = function () { } ;
    window._sp_.config.mms_domain = 'services.hmhost.co.uk' ;
    window._sp_.mms = window._sp_.mms || {};
    window._sp_.mms.cmd = window._sp_.mms.cmd || [];
    window._sp_.config.mms_client_data_callback = function (o) {
       console.log("data callback json: " + o);
    };
    window._sp_.mms.cmd.push( function () {
       window._sp_.mms.startMsg();
    });
  </script>
<link rel="dns-prefetch" href="//tags.crwdcntrl.net" />
<link rel="dns-prefetch" href="//bcp.crwdcntrl.net" />
  <title>Ford Mustang versus Chevrolet Camaro: muscle car twin test | Autocar</title>

      <meta name="MobileOptimized" content="320">
    <meta name="HandheldFriendly" content="true">
    <meta content="IE=edge,chrome=1" http-equiv="X-UA-Compatible">
        <script type="text/javascript">
      var desktop_size = 680;
      if (screen.width < 680) {
        document.write('<meta name="viewport" content="width=device-width, initial-scale=1.0">');
      } else {
        document.write('<meta name="viewport" content="width=1020">');
      }
    </script>
    <meta http-equiv="cleartype" content="on">
  <meta property="fb:pages" content="88466919022">

  <link type="text/css" rel="stylesheet" href="/sites/autocar.co.uk/files/advagg_css/css__9cWqptSUNYq5YedfIwh33VxtugFVWjDdEsblT8GhLKI__quUjyhSfbEukHj8a0hYvzm9VTmPALmSZvA0xfM_Oxzo__1motoMhogn4-LmFTOSQe52-ueFiJ-892YwZHVY35O4I.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/autocar.co.uk/files/advagg_css/css__jjEdIwINPRs5BCpSK59_JjLiKBCs__QLmL3t8MvHU1k__3PWeSxBEp25JZfdB0q4a1THV5KGElJ3sZQngWGz2xDM__1motoMhogn4-LmFTOSQe52-ueFiJ-892YwZHVY35O4I.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/autocar.co.uk/files/advagg_css/css__Xkh31Wk9vWIy3AmGYqGFEEnT_7ZsirqCNHzORkyv-_k__tSFKEsIe9YimcfRUxS5JFhnNAEI0UZk4URk1frXtUd0__1motoMhogn4-LmFTOSQe52-ueFiJ-892YwZHVY35O4I.css" media="screen" />
<link type="text/css" rel="stylesheet" href="/sites/autocar.co.uk/files/advagg_css/css__ZwOabybs7qftPO4zMc_VMH1Do9Ps5TwrOiTMd2P2h84__lt6lSBMGTtGC3qiXvLZdX7UAyoIpxqqACwkGD3ZZziU__1motoMhogn4-LmFTOSQe52-ueFiJ-892YwZHVY35O4I.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/autocar.co.uk/files/advagg_css/css__Tv8T3VaUBDtv8V1OIWJpcbphGcCL_asYVzhcospFmIM__en8bD8rBe41kBmsLyzbedTVyulo6Oxl0ARV1fOCnMUU__1motoMhogn4-LmFTOSQe52-ueFiJ-892YwZHVY35O4I.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/autocar.co.uk/files/advagg_css/css__-cdHCu1r1t-3mCZ7ulAT2RE_i7fvsVxicPYIAL92WQA__jrPNAl1RbZwA3-c2KwTK9fM5kCV8aucVOH9m5WKJbGU__1motoMhogn4-LmFTOSQe52-ueFiJ-892YwZHVY35O4I.css" media="all" />
  <script src="/sites/autocar.co.uk/files/advagg_js/js__SlxZR0T0y0knhPGspoKKlEQqbk_RdNNsHwLrlCQRTSo__U821o8yUel6WHSmnGxanMc4PNMgPMxDM26-qEzVzb5U__1motoMhogn4-LmFTOSQe52-ueFiJ-892YwZHVY35O4I.js" defer="defer"></script>
<script src="/sites/autocar.co.uk/files/advagg_js/js__WZo829Af2Nk0_BRXR_Bf32tKRkPrqjFNlq8MsSh0QSI__wJd2jjHi9-8jhtewxB2qBaCN9PbV6MklJszGkpfvU4Q__1motoMhogn4-LmFTOSQe52-ueFiJ-892YwZHVY35O4I.js"></script>
<script src="/sites/autocar.co.uk/files/advagg_js/js__eGwQfqSrgII6ewGhxnPP7x0QBhJOSUnK3Q9Z8PV8oYQ__WgvV0eBGEfInGxLfprOsP-9G9aHZR201h8ZwG0jDb4E__1motoMhogn4-LmFTOSQe52-ueFiJ-892YwZHVY35O4I.js"></script>
<script src="/sites/autocar.co.uk/files/advagg_js/js__4XngL2QVCTMckM0YOpVP_IE9AfA5bkSolwsFeqDbDxE__kgQTCcfvqec9a7ELnU4eCT1H2uGI9uDLZyvrUWNhfpo__1motoMhogn4-LmFTOSQe52-ueFiJ-892YwZHVY35O4I.js"></script>
<script async="async" src="https://sadmin.brightcove.com/js/BrightcoveExperiences.js"></script>
<script src="/file?q7suqc"></script>
<script src="/sites/autocar.co.uk/files/advagg_js/js__Y6HdhpSmCvc6cgcLZ8IYKAGhQdClp0NKMjTxbtR5doM__ggx2GOMy2UJdNqG1T0LWceVGugVOkeN6PWlXxBZAt1Y__1motoMhogn4-LmFTOSQe52-ueFiJ-892YwZHVY35O4I.js"></script>
<script src="https://widgets.outbrain.com/outbrain.js"></script>
<script src="/sites/autocar.co.uk/files/advagg_js/js__v59SqpkkM6uk3N41m3rGlnDN7SrcfBLsI4rkD9_e_4A__Aue6Kr0D-ft_vXuY8lvRpy5xQ7GikZnwF-h5vTaTrXY__1motoMhogn4-LmFTOSQe52-ueFiJ-892YwZHVY35O4I.js"></script>
<script src="//platform.twitter.com/widgets.js"></script>
<script async="async" src="https://c.amazon-adsystem.com/aax2/amzn_ads.js"></script>
<script async="async" src="//securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script async="async" src="//js-sec.indexww.com/ht/p/185499-278576293522185.js"></script>
<script src="/sites/autocar.co.uk/files/advagg_js/js__AuUFQwZNM-H43HmREdGkZsZC47hJee5UtmZNGl1yB5M__PmUnyNERwYQS9SyQUYeEdDHgSBU2PmOjtEDNwq81LMk__1motoMhogn4-LmFTOSQe52-ueFiJ-892YwZHVY35O4I.js"></script>
<script src="https://cdn.jsdelivr.net/npm/mobile-detect@1.4.3/mobile-detect.min.js"></script>
<script src="/sites/autocar.co.uk/files/advagg_js/js__cFLlsAY4ahd8wAZzXqIfGjKe8sqB8fTzGBKs3w938yk__6y73wdMhjBWRPcnBX1OeNlaPxtuNeEqiQqzQMbeyLwM__1motoMhogn4-LmFTOSQe52-ueFiJ-892YwZHVY35O4I.js"></script>
<script>
     window.googletag = window.googletag || {};
    window.googletag.cmd = window.googletag.cmd || [];
    // Immediately get audiences from local storage and get them loaded
    if (window.localStorage && window.localStorage.getItem) {
      var localStorageAudiences = window.localStorage.getItem("lotame_6252_auds") || "";
      if (localStorageAudiences) {
          googletag.cmd.push(function() {
            window.googletag.pubads().setTargeting("ccaud", localStorageAudiences);
          });
      }
      var localStoragePid = window.localStorage.getItem("_cc_id") || "";
      if (localStoragePid) {
        googletag.cmd.push(function() {
            window.googletag.pubads().setTargeting("lpid", localStoragePid);
        });
      }
    }
    // Callback when targeting audience is ready to push latest audience data
    var audienceReadyCallback = function (profile) {
      // Get audiences in a comma separated string which conforms to Google Ads input format
      var lotameAudiences = profile.getAudienceString(",") || "";
      // Set the target audiences at Google
      googletag.cmd.push(function() {
        window.googletag.pubads().setTargeting("ccaud", lotameAudiences);
      });

      var lotamePid = profile.getProfileId() || "";
      googletag.cmd.push(function() {
        window.googletag.pubads().setTargeting("lpid", lotamePid);
      });
    };
    // Lotame Config
    var lotameTagInput = {
      data: {},
      config: {
        clientId: 6252,
        audienceLocalStorage: true,
        onProfileReady: audienceReadyCallback
      }
    };
    // Lotame initialization
    ! function(input) {
      input = input || {};
      var config = input.config || {};
      var namespace = window["lotame_" + config.clientId] = {};
      namespace.config = config;
      namespace.data = input.data || {};
    } (lotameTagInput);
    </script>
<script src="//tags.crwdcntrl.net/lt/c/6252/lt.min.js"></script>
<script src="/sites/autocar.co.uk/files/advagg_js/js__dqrKXnqpYnFg23fe5wtd3-G_8EGhSywq0veGroqCe1c__L4OBNiOK1pDJ9iZEd9NLhhgOPXcqj-Yi5RUFHAlD2fA__1motoMhogn4-LmFTOSQe52-ueFiJ-892YwZHVY35O4I.js"></script>
<script>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</script>
      <!--[if lt IE 9]>
    <script src="/sites/autocar.co.uk/themes/contrib/zen/js/html5-respond.js"></script>
    <![endif]-->
  </head>
<body class="html not-front not-logged-in page-node page-node- page-node-85349 node-type-news-article   i18n-en two-col section-car-news page-panels" >
      <p id="skip-link">
      <a href="#main-menu" class="element-invisible element-focusable">Jump to navigation</a>
    </p>
    <div class="fake-body">
    <noscript aria-hidden="true"><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5MWZQ7R" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>      <div id="header">
    

    
    
    
          <div class="autocar-header" id="mini-panel-sitewide_header">
      <div class="autocar-header--upper"><div class="block block-autocar-ads-videooverlay even" >
  
      
  
  <div class="ad--wrapper  "><div class="ad--slot" data-slotId="gpt_7294_videooverlay" data-name="videooverlay" data-order="10"></div>
</div>

  
  </div>
<div class="block block-autocar-ads-inimage odd" >
  
      
  
  <div class="ad--wrapper  "><div class="ad--slot" data-slotId="gpt_7294_inimage" data-name="inimage" data-order="10"></div>
</div>

  
  </div>
<div class="block block-autocar-ads-skin even" >
  
      
  
  <div class="ad--wrapper  "><div class="ad--slot" data-slotId="gpt_7294_skin" data-name="skin" data-order="5"></div>
</div>

  
  </div>
<div class="block block-autocar-ads-skin-mobile odd" >
  
      
  
  <div class="ad--wrapper  "><div class="ad--slot" data-slotId="gpt_7294_skin_mobile" data-name="skin_mobile" data-order="2"></div>
</div>

  
  </div>
</div>
    <div class="autocar-header--middle panel-display panel-1col clearfix">
    <div class="panel-panel panel-col">
        <div class="logo-region">
            <div class="logo-region-wrapper">
              
  <div class="site_title"   id="logo-block">

    
    
    
          <a href="/" rel="home" id="logo" title="Home"><img src="https://www.autocar.co.uk/sites/autocar.co.uk/themes/custom/autocar/images/autocar_logo.svg" alt="Home" /></a>    
    
    
  </div>
<div id="block-login-status-login-status" class="block block-login-status first odd">

      
  
               <div id="login-menu-icon" class="item-top">
                <svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 32 32" style="enable-background:new 0 0 32 32;" xml:space="preserve"> <title>Account</title> <desc>Created with Sketch.</desc> <g id="Header-_x26_-Footer"> <g id="AC-Specs---Header-Desktop-HD" transform="translate(-1635.000000, -258.000000)"> <g id="Account" transform="translate(1635.000000, 258.000000)"> <g id="icons_x2F_basic_x2F_avatar_x2F_black" transform="translate(6.857143, 4.571429)"> <g id="avatar"> <path id="Shape_1_" d="M9.1,13.2c-3.5,0-6.3-3-6.3-6.6S5.6,0,9.1,0s6.3,3,6.3,6.6S12.6,13.2,9.1,13.2z M9.1,1.8 C6.6,1.8,4.5,4,4.5,6.6s2.1,4.8,4.6,4.8s4.6-2.2,4.6-4.8S11.6,1.8,9.1,1.8z"/> <path id="Shape_2_" d="M16.4,21H1.7c-0.7,0-1.3-0.5-1.5-1.2c-0.2-0.7,0.1-1.4,0.6-1.8c2.4-1.6,5.3-2.5,8.2-2.5 c2.9,0,5.7,0.9,8.2,2.5c0.6,0.4,0.8,1.1,0.6,1.8C17.7,20.5,17.1,21,16.4,21z M2.4,19.2h13.4c-2-1.2-4.3-1.9-6.7-1.9 C6.7,17.3,4.4,18,2.4,19.2z"/> </g> </g> </g>  </g></g></svg>
               </div>
               <ul class="menu">
                    <li class="first">
                      <a href="/user/login" title="Login to the Autocar website" class="login-link">Login</a>
                    </li>
                    <li class="last">
                      <a href="/user/register" class="register-link" title="Register to the Autocar website">Register</a>
                    </li>
                 </ul>
                 <div class="newsletter-icon newsletter-item-top">
                 <svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 32 32" style="enable-background:new 0 0 32 32;" xml:space="preserve"> <g> <path d="M26.1,8.1c-7.1,3.1-14.1,6.2-21.2,9.3c-0.5,0.2-0.9,0.4-1.4,0.6c-0.3,0.1-0.4,0.3-0.4,0.6c0,0.3,0.2,0.5,0.5,0.5 c0.1,0,0.1,0,0.2,0c1.6,0.4,3.2,0.8,4.8,1.1c0.2,0,0.3,0.1,0.3,0.3c0.8,1.6,1.5,3.3,2.3,4.9c0,0.1,0.1,0.2,0.2,0.3 c0.2,0.3,0.5,0.3,0.8,0.2c0.1-0.1,0.3-0.2,0.4-0.3c1.2-1,2.3-2,3.5-3.1c0.1-0.1,0.2-0.1,0.4-0.1c1.2,0.4,2.3,0.8,3.5,1.1 c0.6,0.2,0.8,0.1,1-0.5c1.8-4.3,3.7-8.5,5.5-12.8c0.2-0.6,0.5-1.1,0.7-1.7c0-0.1,0-0.2,0-0.4C26.8,7.9,26.6,7.9,26.1,8.1z M8.7,19.2c-1.1-0.3-2.1-0.5-3.2-0.8c0,0,0,0,0-0.1c4.8-2.1,9.5-4.2,14.3-6.3c0,0,0,0,0,0c-0.1,0-0.1,0.1-0.2,0.1 c-3.5,2.3-7,4.6-10.5,6.8C9.1,19.2,8.9,19.3,8.7,19.2z M12.2,20.8c-0.2,0.9-0.4,1.9-0.6,2.9c-0.6-1.2-1.1-2.4-1.7-3.6 c3.3-2.2,6.7-4.4,10-6.5c0,0,0,0,0,0c-1,0.9-2.1,1.8-3.1,2.8c-1.4,1.3-2.9,2.6-4.3,3.8C12.3,20.4,12.2,20.6,12.2,20.8z M12.7,23.9 c0.2-0.8,0.3-1.6,0.5-2.3c0.5,0.2,1,0.3,1.6,0.5C14.1,22.7,13.4,23.2,12.7,23.9z M19.9,22.5c-2-0.6-3.9-1.3-5.9-1.9 c3.6-3.2,7.3-6.5,10.9-9.7c0,0,0,0,0,0C23.2,14.7,21.5,18.6,19.9,22.5z"></path> </g> </svg>
                 </a>
               </div>
               <ul class="newsletter-menu">
                 <li class="first">
                   <a href="https://pages.haymarket.com/autocar/ACAR-Enews-full" target="_blank" title="Sign up to newsletter">Newsletter sign up</a>
                 </li>
               </ul>
</div>
<div class="block block-autocar-mobile-nav odd" >
  
        <h2 class="block-title">Mobile navigation</h2>
    
  
  <div class="mobile-navigation--button" role="button"><div class="svg-image">
    <svg viewBox="0 0 100 100">
      <use xlink:href="/sites/autocar.co.uk/themes/custom/autocar/images/mobilemenu.svg#Layer_1"></use>
    </svg>
  </div>
<span class="title sr-only">Menu</span></div><div class="mobile-navigation--pane"><h3>Tabs</h3><div class="nav--tabs"><div class="pane__inner"><div class="item-list"><ul><li class="menu-main active first" data-toggle="nav-pane--menu" role="button">Menu</li>
<li class="menu-user" data-toggle="nav-pane--user" role="button"><div class="user--anon nav__icon"><div class="svg-image">
    <svg viewBox="0 0 100 100">
      <use xlink:href="/sites/autocar.co.uk/themes/custom/autocar/images/Account.svg#Layer_1"></use>
    </svg>
  </div>
</div><div class="nav__title">My account</div></li>
<li class="menu-newsletter last" role="button"><div class="nav-newsletter nav__icon"><a href="https://pages.haymarket.com/autocar/ACAR-Enews-full" title="Subscribe to the Autocar newsletter" target="_blank"><div class="svg-image">
    <svg viewBox="0 0 100 100">
      <use xlink:href="/sites/autocar.co.uk/themes/custom/autocar/images/Newsletter.svg#Layer_1"></use>
    </svg>
  </div>
</a></div><div class="nav__title">Subscribe to the Autocar newsletter</div></li>
</ul></div></div></div><h3>main menu</h3><div class="nav--pane nav-pane--menu active"><div class="pane__inner"><ul class="menu links primary-links expanded"><li class="menu__item is-leaf first leaf"><a href="/" title="" class="menu__link">Home</a></li>
<li class="menu__item is-leaf leaf"><a href="/car-reviews" class="menu__link">Car Reviews</a></li>
<li class="menu__item is-leaf leaf"><a href="/car-news" class="menu__link">Car News</a></li>
<li class="menu__item is-leaf leaf"><a href="/video" class="menu__link">Video</a></li>
<li class="menu__item is-leaf leaf"><a href="/opinion" class="menu__link">Opinion</a></li>
<li class="menu__item is-leaf leaf"><a href="https://pages.haymarket.com/autocar/ACAR-Enews-full" title="" class="menu__link">Newsletter</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.autocar.co.uk/car-news/best-cars" title="Top 10 cars by segment" class="menu__link">Best cars</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.autocar.co.uk/car-news/industry" title="All the news from the Industry" class="menu__link">Business</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.autocar.co.uk/driversofchange" title="Enter our competition to innovate the car industry" class="menu__link">Drivers of Change</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.themagazineshop.com/easms20c/autocar/" title="" class="menu__link">6 issues for £6</a></li>
<li class="menu__item is-expanded last expanded"><a href="https://www.autocar.co.uk/tyres/" title="" class="menu__link">Offers</a><ul class="menu links primary-links expanded"><li class="menu__item is-leaf first leaf"><a href="https://www.autocar.co.uk/tyres/" title="Whether you&#039;re looking for cheap, premium or quality tyres, look no further than Autocar Tyres." class="menu__link menu-item--coloured">Tyres</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.ala.co.uk/autocargap/?utm_source=autocar.co.uk&amp;utm_medium=main+nav&amp;utm_campaign=GAP+Insurance&amp;ala_p=AUTOCAR12" title="" class="menu__link">Gap Insurance</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.ala.co.uk/autocargap/?utm_source=autocar.co.uk&amp;utm_medium=main+nav&amp;utm_campaign=GAP+Insurance&amp;ala_p=AUTOCAR12" title="" class="menu__link">Warranty</a></li>
<li class="menu__item is-leaf last leaf"><a href="http://www.autocar.co.uk/car-leasing" title="" class="menu__link">Leasing</a></li>
</ul></li>
</ul></div></div><h3>User block</h3><div class="nav--pane nav-pane--user"><div class="pane__inner"><div class="item-list"><ul><li class="first">You are logged out.</li>
<li><a href="/user">Login</a></li>
<li class="last"><a href="/user/register">Register</a></li>
</ul></div></div></div><div class="close" role="button"><div class="svg-image">
    <svg viewBox="0 0 100 100">
      <use xlink:href="/sites/autocar.co.uk/themes/custom/autocar/images/cross.svg#Layer_1"></use>
    </svg>
  </div>
<div class="sr-only">Close</div></div></div>
  
  </div>
            </div>
        </div>
      
  <nav   id="top-login-wrapper" >

    
    
    
          <ul class="menu links primary-links expanded"><li class="menu__item is-leaf first leaf"><a href="/" title="" class="menu__link">Home</a></li>
<li class="menu__item is-leaf leaf"><a href="/car-reviews" class="menu__link">Car Reviews</a></li>
<li class="menu__item is-leaf leaf"><a href="/car-news" class="menu__link">Car News</a></li>
<li class="menu__item is-leaf leaf"><a href="/video" class="menu__link">Video</a></li>
<li class="menu__item is-leaf leaf"><a href="/opinion" class="menu__link">Opinion</a></li>
<li class="menu__item is-leaf leaf"><a href="https://pages.haymarket.com/autocar/ACAR-Enews-full" title="" class="menu__link">Newsletter</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.autocar.co.uk/car-news/best-cars" title="Top 10 cars by segment" class="menu__link">Best cars</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.autocar.co.uk/car-news/industry" title="All the news from the Industry" class="menu__link">Business</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.autocar.co.uk/driversofchange" title="Enter our competition to innovate the car industry" class="menu__link">Drivers of Change</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.themagazineshop.com/easms20c/autocar/" title="" class="menu__link">6 issues for £6</a></li>
<li class="menu__item is-expanded last expanded"><a href="https://www.autocar.co.uk/tyres/" title="" class="menu__link">Offers</a><ul class="menu links primary-links expanded"><li class="menu__item is-leaf first leaf"><a href="https://www.autocar.co.uk/tyres/" title="Whether you&#039;re looking for cheap, premium or quality tyres, look no further than Autocar Tyres." class="menu__link menu-item--coloured">Tyres</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.ala.co.uk/autocargap/?utm_source=autocar.co.uk&amp;utm_medium=main+nav&amp;utm_campaign=GAP+Insurance&amp;ala_p=AUTOCAR12" title="" class="menu__link">Gap Insurance</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.ala.co.uk/autocargap/?utm_source=autocar.co.uk&amp;utm_medium=main+nav&amp;utm_campaign=GAP+Insurance&amp;ala_p=AUTOCAR12" title="" class="menu__link">Warranty</a></li>
<li class="menu__item is-leaf last leaf"><a href="http://www.autocar.co.uk/car-leasing" title="" class="menu__link">Leasing</a></li>
</ul></li>
</ul>    
    
    
  </nav>
    </div>
  </div>
      <div class="autocar-header--bottom"><div class="block block-autocar-ads-banner2 even" >
  
      
  
  <div class="ad--wrapper  "><div class="ad--slot" data-slotId="gpt_7294_banner2" data-name="banner2" data-order="5"></div>
</div>

  
  </div>
</div>
  </div>
    
    
    
  </div>

<div id="container"> <!-- page wrapper -->
    <div id="page">
      <div class="block block-page-breadcrumb even" >
  
      
  
  <nav class="breadcrumb" role="navigation"><h2 class="element-invisible">You are here</h2><ol><li><a href="/car-news">Car news</a><span class="separator"> › </span></li><li><a href="/topics/features">Features</a><span class="separator"> › </span></li><li>Ford Mustang versus Chevrolet Camaro: muscle car twin test</li></ol></nav>
  
  </div>
<div class="block block-autocar-ads-masthead1 even" >
  
      
  
  <div class="ad--wrapper  "><div class="ad--slot" data-slotId="gpt_7294_masthead1" data-name="masthead1" data-order="2"></div>
</div>

  
  </div>
<div class="block block-autocar-ads-banner1 odd" >
  
      
  
  <div class="ad--wrapper  "><div class="ad--slot" data-slotId="gpt_7294_banner1" data-name="banner1" data-order="3"></div>
</div>

  
  </div>
      
<div >
  <!-- start of featured wrapper -->
  
      <div class="content-header">
      
  <div class="nav-title"  >

    
    
    
          <h1  itemprop="name">Ford Mustang versus Chevrolet Camaro: muscle car twin test</h1>    
    
    
  </div>

  <div class="views-field-field-intro-pull-quote-value"  >

    
    
    
          <div class="field field-name-field-standfirst field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even">We compare two brawny, V8-engined old-school muscle cars, to see which best suits a UK buyer</div></div></div>    
    
    
  </div>
    </div>
  
  <!-- start of left sidebar -->
  
  <!-- start of center column -->
  <div class="article-section clearfix article-section-first">
    <div class="col-center">

              <div class="content-top">
          <div class="block block-carousel even" >
  
      
  
  <div id="carousel-wrapper">
  <div id="carousel-dimmer"></div>
  <div id="carousel-mover">
    <div id="sitewide-slider" class="flexslider"><ul class="slides"><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/gallery_slide/public/images/car-reviews/first-drives/legacy/mustang-camaro-2761.jpg?itok=3o2RB-DQ" width="900" height="596" alt="Mustang vs Camaro" /><blockquote class="image-field-caption">
  Chevrolet’s V8 engine has 31bhp more power than Ford’s and, crucially, more character

</blockquote>
</li><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/gallery_slide/public/images/car-reviews/first-drives/legacy/mustang-camaro-2763.jpg?itok=AoyI1qIe" width="900" height="596" alt="Mustang vs Camaro" /><blockquote class="image-field-caption">
  With so much power and torque going to their rear wheels, both the Camaro and Mustang are natural born sliders</blockquote>
</li><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/gallery_slide/public/images/car-reviews/first-drives/legacy/mustang-camaro-2764.jpg?itok=F8zTJMlP" width="900" height="596" alt="Mustang vs Camaro" /><blockquote class="image-field-caption">
  The Camaro was an Autobot in Transformers</blockquote>
</li><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/gallery_slide/public/images/car-reviews/first-drives/legacy/mustang-camaro-2766.jpg?itok=TdiDhio2" width="900" height="596" alt="Mustang vs Camaro" /><blockquote class="image-field-caption">
  Camaro’s eight-speed automatic gearbox works well enough, but we would stick with the more involving – and £1690 cheaper – six-speed manual

</blockquote>
</li><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/gallery_slide/public/images/car-reviews/first-drives/legacy/mustang-camaro-2767.jpg?itok=IexPAaPO" width="900" height="596" alt="Mustang vs Camaro" /><blockquote class="image-field-caption">
  The Camaro’s surprisingly quick steering jars somewhat with the car’s not insubstantial 1659kg kerb weight</blockquote>
</li><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/gallery_slide/public/images/car-reviews/first-drives/legacy/mustang-camaro-2768.jpg?itok=3nrw8JKQ" width="900" height="596" alt="Mustang vs Camaro" /><blockquote class="image-field-caption">
  Though now available outside America, the sixth-generation Mustang is unmistakably a car built for the long, wide roads of home</blockquote>
</li><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/gallery_slide/public/images/car-reviews/first-drives/legacy/mustang-camaro-2771.jpg?itok=ljwk5Np_" width="900" height="596" alt="Mustang vs Camaro" /></li><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/gallery_slide/public/images/car-reviews/first-drives/legacy/mustang-camaro-2790.jpg?itok=EtaH8_UJ" width="900" height="596" alt="Mustang vs Camaro" /><blockquote class="image-field-caption">
  Right-hand drive isn’t quintessential Mustang but those large round dials certainly are</blockquote>
</li><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/gallery_slide/public/images/car-reviews/first-drives/legacy/mustang-camaro-2801.jpg?itok=rCGrAHYA" width="900" height="596" alt="Mustang vs Camaro" /><blockquote class="image-field-caption">
  For an old-fashioned muscle car, the latest Camaro has a pleasingly refined cabin</blockquote>
</li></ul></div><div id="sitewide-carousel" class="flexslider"><ul class="slides"><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/flexslider_thumbnail/public/images/car-reviews/first-drives/legacy/mustang-camaro-2761.jpg?itok=bxcjpml-" width="160" height="100" alt="Mustang vs Camaro" /></li><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/flexslider_thumbnail/public/images/car-reviews/first-drives/legacy/mustang-camaro-2763.jpg?itok=WoN65CFJ" width="160" height="100" alt="Mustang vs Camaro" /></li><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/flexslider_thumbnail/public/images/car-reviews/first-drives/legacy/mustang-camaro-2764.jpg?itok=RxKylmO9" width="160" height="100" alt="Mustang vs Camaro" /></li><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/flexslider_thumbnail/public/images/car-reviews/first-drives/legacy/mustang-camaro-2766.jpg?itok=gqVBX1jS" width="160" height="100" alt="Mustang vs Camaro" /></li><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/flexslider_thumbnail/public/images/car-reviews/first-drives/legacy/mustang-camaro-2767.jpg?itok=59bbAIZv" width="160" height="100" alt="Mustang vs Camaro" /></li><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/flexslider_thumbnail/public/images/car-reviews/first-drives/legacy/mustang-camaro-2768.jpg?itok=rIf2yFnu" width="160" height="100" alt="Mustang vs Camaro" /></li><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/flexslider_thumbnail/public/images/car-reviews/first-drives/legacy/mustang-camaro-2771.jpg?itok=-1dwpwyc" width="160" height="100" alt="Mustang vs Camaro" /></li><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/flexslider_thumbnail/public/images/car-reviews/first-drives/legacy/mustang-camaro-2790.jpg?itok=HpTvVXh9" width="160" height="100" alt="Mustang vs Camaro" /></li><li><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/flexslider_thumbnail/public/images/car-reviews/first-drives/legacy/mustang-camaro-2801.jpg?itok=4jT-neOC" width="160" height="100" alt="Mustang vs Camaro" /></li></ul></div>    <div class="close-gallery">Close</div>
  </div>
</div>
  
  </div>
<div class="block block-service-links-service-links odd" >
  
      
  
  <div class="service-links"><div class="item-list"><ul><li class="first"><a href="https://www.facebook.com/plugins/like.php?href=https%3A//www.autocar.co.uk/car-news/features/ford-mustang-versus-chevrolet-camaro-muscle-car-twin-test&amp;layout=button_count&amp;show_faces=false&amp;action=like&amp;colorscheme=light&amp;width=65&amp;height=21&amp;font=&amp;locale=&amp;share=false" title="I Like it" class="service-links-facebook-like" rel="nofollow"><span class="element-invisible">Facebook Like</span></a></li>
<li class="last"><a href="https://twitter.com/share?url=https%3A//www.autocar.co.uk/car-news/features/ford-mustang-versus-chevrolet-camaro-muscle-car-twin-test&amp;count=horizontal&amp;via=&amp;text=Ford%20Mustang%20versus%20Chevrolet%20Camaro%3A%20muscle%20car%20twin%20test&amp;counturl=https%3A//www.autocar.co.uk/car-news/features/ford-mustang-versus-chevrolet-camaro-muscle-car-twin-test" class="twitter-share-button service-links-twitter-widget" title="Tweet This" rel="nofollow"><span class="element-invisible">Tweet Widget</span></a></li>
</ul></div></div>
  
  </div>
        </div>
      
      <div class="main two-col-content">
                <div class="content">
                      
  <div class="personality-block clearfix"  >

    
    
    
          
  <div class="personality-info"  >

    
    
    
          
  <div class="personality"  >

    
    
    
          <div itemtype="https://schema.org/Person" itemscope="" itemprop="author" class="personality">by <a title="Dan Prosser" href="https://www.autocar.co.uk/users/dan-prosser"><span itemprop="name">Dan Prosser</span></a></div>    
    
    
  </div>

  <div class="personality-date"  >

    
    
    
          26 March 2020    
    
    
  </div>
    
    
    
  </div>


    
    
    
          <div class="personality-twitter"><div class="field field-name-field-personality-reference field-type-entityreference field-label-hidden"><div class="field-items"></div></div></div>    
    
    
    
    
    
  </div>
<div class="block block-node odd" >
  
      
  
  <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even"><div class="iframe-container-www-youtube-com">
<p>Whichever good ol’boy it was who first bawled the phrase ‘There ain’t no replacement for displacement!’ way back when – almost certainly from beneath the wide brim of a Stetson, rye whiskey held aloft – he probably had a point at the time.</p>
<p>If you wanted to go faster, you needed more cubes. But in the age of smartphones and cryptocurrencies, it’s a bit of a quaint notion. There are, after all, countless other ways of making a car shift along more quickly, such as <a href="https://www.autocar.co.uk/car-news/new-cars/2018-bmw-7-series-facelift-bring-more-hybridisation-and-sharper-looks">hybridisation</a> and turbocharging, or perhaps using clever lightweight materials so that what displacement you do have can work a lot harder.</p><div class="blocks-wrapper"><div id="block-autocar-ads-native-slot" class="block block-autocar-ads first odd">

      
  <div class="ad--wrapper  "><div class="ad--slot" data-slotId="gpt_7294_native_slot" data-name="native_slot" data-order="10"></div>
</div>

</div>
</div>
<p>And yet, there really is no replacement for displacement. Nothing else comes close to the soaring soundtrack of a great big atmospheric engine, and nothing matches the frantic power delivery – the kind that makes you screw your face into a tight ball – that you get from six or eight big unassisted pistons pounding up and down.</p>
<p><img alt="" src="https://www.autocar.co.uk/sites/autocar.co.uk/files/images/car-reviews/first-drives/legacy/mustang-camaro-2763.jpg" /></div></div></div></div></div>                              </div>
      </div>
              <div class="mini-column">
          
  <div class="our-verdict"  >

    
          <h2>Our Verdict</h2>    
    
          <div class="view view-fautocar-car-verdict view-id-fautocar_car_verdict view-display-id-panel_pane_1 view-dom-id-590e785f7559ec1e8b1cb7cb72a344b1">
        
  
  
      <div class="view-content">
        <div>
    <div class="field field-name-title field-type-ds field-label-hidden"><div class="field-items"><div class="field-item even"><h3><a href="/car-review/ford/mustang">Ford Mustang </a></h3></div></div></div><div class="field field-name-field-intro-picture field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/car-review/ford/mustang"><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/article_image_150/public/ford-mustang-web-2016-052.jpg?itok=f4kAmpJA" width="150" height="100" alt="Ford Mustang V8 Fastback" /></a></div></div></div><p>The Ford Mustang is available in the UK in right-hand drive for the first time, but does the rest of this American muscle car fit the UK car scene?</p>  </div>
    </div>
  
  
  
  
  
  
</div>    
    
    
  </div>
        </div>
          </div>

          <div class="col-right col-right-desktop">
        <div class="block block-sitewide-sidebar-type-3 even" >
  
      
  
  <div class="block block-autocar-ads-mpu-flexible1 even" >
  
      
  
  <div class="ad--title">Advertisement</div>
<div class="ad--wrapper ad--slider ad--slider--large"><div class="ad--slot" data-slotId="gpt_7294_mpu_flexible1" data-name="mpu_flexible1" data-order="1"></div>
</div>

  
  </div>
<div class="block block-autocar-ads-mpu1 odd" >
  
      
  
  <div class="ad--title">Advertisement</div>
<div class="ad--wrapper ad--slider "><div class="ad--slot" data-slotId="gpt_7294_mpu1" data-name="mpu1" data-order="1"></div>
</div>

  
  </div>

  <div class="car-finder"  >

    
          <h3>Find an Autocar car review</h3>    
    
          <form action="/car-news/technology/under-skin-how-porsche-revived-flat-six-engines-718" method="get" id="car-finder" accept-charset="UTF-8"><div><div class="form-item form-type-select form-item-make">
 <select id="car-finder-make-chooser" name="make" class="form-select"><option value="0" selected="selected">Choose a make</option><option value="1286">Abarth</option><option value="2104">AC Schnitzer</option><option value="2112">Aiways</option><option value="1250">Allard</option><option value="90">Alfa Romeo</option><option value="91">Alpina</option><option value="1502">Alpine</option><option value="92">Ariel</option><option value="94">Ascari</option><option value="95">Aston Martin</option><option value="93">Audi</option><option value="97">BAC</option><option value="96">Bentley</option><option value="98">BMW</option><option value="1758">Borgward</option><option value="99">Bowler</option><option value="100">Bugatti</option><option value="1149">BYD</option><option value="1776">Byton</option><option value="101">Cadillac</option><option value="102">Caparo</option><option value="103">Caterham</option><option value="1719">Changan Auto</option><option value="104">Chevrolet</option><option value="105">Chrysler</option><option value="106">Citroen</option><option value="1916">Cupra</option><option value="1965">De Tomaso</option><option value="108">Dacia</option><option value="1823">Dallara</option><option value="1160">David Brown</option><option value="109">Dodge</option><option value="1275">DS</option><option value="2042">Dyson</option><option value="1158">Eagle</option><option value="1066">Elemental</option><option value="110">Eterniti</option><option value="111">Ferrari</option><option value="112">Fiat</option><option value="113">Fisker</option><option value="114">Ford</option><option value="116">Great Wall</option><option value="1166">Geely</option><option value="115">Ginetta</option><option value="117">Gumpert</option><option value="1309">Hennessey</option><option value="1956">Hispano Suiza</option><option value="118">Honda</option><option value="1152">Hongqi</option><option value="119">Hyundai</option><option value="2194">Ineos</option><option value="1961">Ineos Automotive</option><option value="120">Infiniti</option><option value="1259">Isuzu</option><option value="1144">ItalDesign</option><option value="1947">JAC</option><option value="121">Jaguar</option><option value="2168">Jannarelly</option><option value="2151">JCB</option><option value="122">Jeep</option><option value="1715">JIA</option><option value="1255">Ken Okuyama</option><option value="123">Kia</option><option value="124">Koenigsegg</option><option value="125">KTM</option><option value="126">Lada</option><option value="127">Lamborghini</option><option value="1302">Lancia</option><option value="128">Land Rover</option><option value="129">Lexus</option><option value="1739">Lincoln</option><option value="130">Lotus</option><option value="1765">Lynk &amp; Co</option><option value="1373">Mahindra</option><option value="131">Marcos</option><option value="132">Maserati</option><option value="133">Maybach</option><option value="134">Mazda</option><option value="135">McLaren</option><option value="923">Mercedes-AMG</option><option value="136">Mercedes-Benz</option><option value="1167">Mercedes-Maybach</option><option value="137">MG Motor</option><option value="139">Mini</option><option value="138">Mia</option><option value="140">Mitsubishi</option><option value="141">Morgan</option><option value="1840">MS-RT</option><option value="142">Murray</option><option value="1487">NextEV</option><option value="1934">Nio</option><option value="143">Nissan</option><option value="144">Noble</option><option value="1808">Oldsmobile</option><option value="1231">Opel</option><option value="145">Pagani</option><option value="146">Perodua</option><option value="147">Peugeot</option><option value="1816">Pininfarina</option><option value="2071">Polestar</option><option value="148">Porsche</option><option value="149">Proton</option><option value="150">Qoros</option><option value="151">Radical</option><option value="1919">Ram</option><option value="152">Renault</option><option value="1813">Rimac</option><option value="1381">Riversimple</option><option value="1142">Roewe</option><option value="153">Rolls-Royce</option><option value="1803">Rover</option><option value="154">Saab</option><option value="155">Seat</option><option value="1147">Senova</option><option value="1305">Shelby</option><option value="1709">Sin</option><option value="156">Skoda</option><option value="157">Smart</option><option value="158">Spyker</option><option value="159">SRT</option><option value="160">Ssangyong</option><option value="161">SSC</option><option value="162">Subaru</option><option value="163">Suzuki</option><option value="164">Tata</option><option value="165">Tesla</option><option value="1239">Tiger</option><option value="166">Toniq</option><option value="167">Toyota</option><option value="1798">Triumph</option><option value="168">Tushek</option><option value="1110">TVR</option><option value="169">Vauxhall</option><option value="891">Vencer</option><option value="170">Veritas</option><option value="171">Volkswagen</option><option value="172">Volvo</option><option value="173">Vuhl</option><option value="174">Westfield</option><option value="1761">Wey</option><option value="2142">Xpeng</option><option value="175">Zenos</option><option value="176">Zenvo</option><option value="1226">Zolfe</option><option value="1235">Zoyte</option></select>
</div>
<div class="form-item form-type-select form-item-model form-disabled">
 <select disabled="disabled" id="car-finder-model-chooser" name="model" class="form-select"><option value="0">Then a model</option></select>
</div>
<input type="submit" id="car-finder-search" name="op" value="Search" class="form-submit" /></div></form>    
    
    
  </div>

  <div class="first-drives driven-this-week view-pane"  >

    
          <h2>Driven this week</h2>    
    
          <div class="view view-fautocar-first-drives-nodes view-id-fautocar_first_drives_nodes view-display-id-panel_pane_1 view-dom-id-30f41a94a25ed0620485c0d3f56faf5b">
        
  
  
      <div class="view-content">
      <div class="item-list">    <ul>          <li class="views-row views-row-1 views-row-odd views-row-first">  
  <div class="views-field views-field-field-main-image">        <div class="field-content"><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/article_image_65/public/images/car-reviews/first-drives/legacy/1-renault-zoe-2020-uk-fd-hero-front.jpg?itok=9sneYTOh" width="65" height="43" alt="Renault Zoe 2020 UK first drive review - hero front" title="Renault Zoe 2020 UK first drive review - hero front" /></div>  </div>  
  <div class="views-field views-field-published-at-1">        <span class="field-content">25 March 2020</span>  </div>  
  <div class="views-field views-field-type">        <span class="field-content">First Drive</span>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/car-review/renault/zoe/first-drives/renault-zoe-2020-uk-review">Renault Zoe 2020 UK review</a></span>  </div>  
  <div class="views-field views-field-field-standfirst">        <div class="field-content">Modest power and range gains make for a more well-rounded EV that is no...</div>  </div></li>
          <li class="views-row views-row-2 views-row-even">  
  <div class="views-field views-field-field-main-image">        <div class="field-content"><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/article_image_65/public/images/car-reviews/first-drives/legacy/1-land-rover-defender-110-2020-fd-hero-front.jpg?itok=QkFOe1Bm" width="65" height="43" alt="Land Rover Defender 110 S 2020 first drive review - hero front" title="Land Rover Defender 110 S 2020 first drive review - hero front" /></div>  </div>  
  <div class="views-field views-field-published-at-1">        <span class="field-content">25 March 2020</span>  </div>  
  <div class="views-field views-field-type">        <span class="field-content">First Drive</span>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/car-review/land-rover/defender/first-drives/land-rover-defender-110-s-2020-review">Land Rover Defender 110 S 2020 review</a></span>  </div>  
  <div class="views-field views-field-field-standfirst">        <div class="field-content">Does the new Defender have the off-road prowess to justify its name – and how...</div>  </div></li>
          <li class="views-row views-row-3 views-row-odd views-row-last">  
  <div class="views-field views-field-field-main-image">        <div class="field-content"><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/article_image_65/public/images/car-reviews/first-drives/legacy/1-ford-kuga-2020-uk-fd-hero-front.jpg?itok=sE5MvkBA" width="65" height="43" alt="Ford Kuga ST-Line PHEV 2020 UK first drive review - hero front" title="Ford Kuga ST-Line PHEV 2020 UK first drive review - hero front" /></div>  </div>  
  <div class="views-field views-field-published-at-1">        <span class="field-content">25 March 2020</span>  </div>  
  <div class="views-field views-field-type">        <span class="field-content">First Drive</span>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/car-review/ford/kuga/first-drives/ford-kuga-25-phev-st-line-2020-uk-review">Ford Kuga 2.5 PHEV ST-Line 2020 UK review</a></span>  </div>  
  <div class="views-field views-field-field-standfirst">        <div class="field-content">All-new version of Ford&#039;s best-selling SUV, driven here in plug-in...</div>  </div></li>
      </ul></div>    </div>
  
  
  
  
  
  
</div>    
    
    
  </div>

  
  </div>
              </div>

      </div>

                    <div class="mid-content-region">
          <div class="block block-autocar-ads-masthead2 even" >
  
      
  
  <div class="ad--wrapper  "><div class="ad--slot" data-slotId="gpt_7294_masthead2" data-name="masthead2" data-order="3"></div>
</div>

  
  </div>
        </div>
            <div class="article-section" data-sticky-container>
          <div class="col-center">
            <div class="lower-content-region">
              
<p>You just can’t beat it. But in the affordable performance car sector, those high-capacity, naturally aspirated engines have more or less disappeared recently, done for one by one by relentlessly punitive emissions regulations. Everything’s got a turbocharger on it these days. Well, not quite everything: there is still the good ol’ American muscle car.</p>
<p>The latest <a href="https://www.autocar.co.uk/car-review/ford/mustang">Ford Mustang</a> is a global car, which means you can have it in right-hand drive. It even has European-style multi-link rear suspension, rather than a live rear axle. The sixth-generation <a href="https://www.autocar.co.uk/car-review/chevrolet/camaro">Chevrolet Camaro</a>, meanwhile, is close to 100kg lighter than the version it replaces and it too uses a more sophisticated multi-link rear end.</p>
<p><span>In some very important ways, then, the latest breed of American muscle car has been dragged into the 21st century. In one crucial department, though, the Mustang and the Camaro are still deliberately and deliciously old-school: both have heaving great V8s that make their power through glorious old displacement alone, with not a turbocharger or electric motor in sight. The Ford’s measures 4951cc, the Chevrolet’s even bigger at 6162cc.</span></p>
<p><img alt="" src="https://www.autocar.co.uk/sites/autocar.co.uk/files/images/car-reviews/first-drives/legacy/mustang-camaro-2764.jpg" /></p>
<p>That’s all well and good. Yes, they’re relatively modern cars these days, just with old-style V8 engines, but let’s be realistic about this: you wouldn’t actually consider owning one in the UK, would you?</p>
<p>It’s easier to make a case for the £38,095 Mustang now than ever before, and although the Camaro, which is a fraction more expensive at £39,040 (prices correct at time of writing), remains left-hand drive only, it is now being sold here by an official dealer, Surrey-based Ian Allan Motors. If you’ve ever felt that muscle car itch, there’s never been a better time to scratch it.</p>
<p>You could drive the Camaro every day for a year in the UK and be pretty damn sure of never seeing another one. Just as <a href="https://www.autocar.co.uk/car-reviews/ford">Ford</a> did with the Mustang – and like <a href="https://www.autocar.co.uk/car-reviews/dodge">Dodge</a> managed with its Challenger – Chevrolet has brilliantly reimagined the overall aesthetic of the original Camaro in this latest model. It looks right up to date, but it’s still unmistakably a Camaro.</p>
<p>Aside from their big V8s, American muscle cars have always been characterised by one other thing: completely shonky interiors. It’s been part of the trade-off. You put up with scratchy plastics and shoddy build quality because the list price was so modest and there was a whacking great V8 up front. That’s still very true of the Mustang. Its cabin is fit for purpose but the materials are unimpressive and the dashboard design is slavish to the 1960s original to the point of pastiche. It’s all just a bit tacky.</p>
<p><img alt="" src="https://www.autocar.co.uk/sites/autocar.co.uk/files/images/car-reviews/first-drives/legacy/mustang-camaro-2766.jpg" />            </div>
          </div>
                      <div class="sidebar-third col-right">
              <div class="block block-autocar-ads-mpu-flexible2 even  " >
  
      
  
  <div class="ad--wrapper   ad--sticky"><div class="ad--slot" data-slotId="gpt_7294_mpu_flexible2" data-name="mpu_flexible2" data-order="4"></div>
</div>

  
  </div>
<div class="block block-autocar-ads-mpu2 odd" >
  
      
  
  <div class="ad--title">Advertisement</div>
<div class="ad--wrapper ad--slider "><div class="ad--slot" data-slotId="gpt_7294_mpu2" data-name="mpu2" data-order="4"></div>
</div>

  
  </div>
            </div>
                </div>
                  <div class="mid-content-region">
          <div class="block block-autocar-ads-masthead3 odd" >
  
      
  
  <div class="ad--wrapper  "><div class="ad--slot" data-slotId="gpt_7294_masthead3" data-name="masthead3" data-order="10"></div>
</div>

  
  </div>
        </div>
            <div class="article-section" data-sticky-container>
          <div class="col-center">
            <div class="lower-content-region">
              
<p>The Camaro, meanwhile – in what must be a first for this sort of machine – feels like a premium car from within. The material quality is much better and the design is clean and simple. There are elegant flourishes too, like the low-set central air vents that double up as heater controls. Overall, it’s a more pleasant environment, although it should be acknowledged that the Mustang’s steering wheel does reach out a lot further, giving a more natural seating position.</p>
<p>As far as the steering itself goes, though, it’s the Camaro’s that feels better. It does initially, anyway. Whereas the Mustang’s helm is quite vague and imprecise at first, the Camaro’s is tight, quick and very direct, making the car seem lighter and smaller. But when you start to really lean on the Chevy’s front axle in corners, you realise that the heightened rate of the rack is a bit of an artifice because, although the front end does keep up with it, the rest of the chassis doesn’t. What you feel from behind the wheel is the front axle darting hurriedly into a bend, then the car tripping over itself as it struggles to haul its 1659kg mass into the corner. That makes the Camaro feel just a touch clumsy.</p>
<p>Ford’s engineers, by comparison, seem to have been bold enough to allow the Mustang to behave like a muscle car. They haven’t tried to make it feel more athletic than it really is. So although its steering is quite loose to begin with, it is actually better matched to the rest of the chassis. Once the two cars are loaded up mid-corner, it’s the Ford that’s the easier car to read too, the one that gives you a clearer idea of what’s going on down below. You feel just a little more empowered to drive the Mustang right up to the limit of grip.</p>
<p><img alt="" src="https://www.autocar.co.uk/sites/autocar.co.uk/files/images/car-reviews/first-drives/legacy/mustang-camaro-2768.jpg" /></p>
<p>Both cars may well be more modern now with their multi-link rear suspension arrangements, but both still feel completely different to any European four-seat coupé, both still with a definite American flavour. They take up a lot of road and, rather than being darty and lithe, they’re both somewhat relaxed and sedate. They move to the rhythm of air raid sirens. You don’t try to really hustle them along a road, then, but instead stroke them along at good speed, pouring them smoothly into bends.</p>
<p>The Mustang is a global car but still most at home on the kind of wide, endlessly long and arrow-straight roads that demand a long-legged gait and fluid, rangy suspension.</p>
<p>The kind of road, frankly, that we don’t have a great deal of here in the UK. Our back roads tend to be tight and twisty with three-dimensional surfaces. Aside from feeling quite sizeable, then, both cars also feel very busy, rising and falling markedly with the road surface and bouncing a little on their springs, getting heavy in compressions and very light over crests. Of the two, though, it’s the Camaro – at least with this test car’s optional magnetic dampers – that has the tauter body control.            </div>
          </div>
                      <div class="sidebar-third col-right">
              <div class="block block-autocar-ads-mpu-flexible3 even" >
  
      
  
  <div class="ad--wrapper   ad--sticky"><div class="ad--slot" data-slotId="gpt_7294_mpu_flexible3" data-name="mpu_flexible3" data-order="4"></div>
</div>

  
  </div>
<div class="block block-autocar-ads-mpu3 odd" >
  
      
  
  <div class="ad--title">Advertisement</div>
<div class="ad--wrapper ad--slider "><div class="ad--slot" data-slotId="gpt_7294_mpu3" data-name="mpu3" data-order="10"></div>
</div>

  
  </div>
            </div>
                </div>
                  <div class="mid-content-region">
          <div class="block block-autocar-ads-masthead3 odd" >
  
      
  
  <div class="ad--wrapper  "><div class="ad--slot" data-slotId="gpt_7294_masthead3" data-name="masthead3" data-order="10"></div>
</div>

  
  </div>
        </div>
            <div class="article-section" data-sticky-container>
          <div class="col-center">
            <div class="lower-content-region">
              
<p><img alt="" src="https://www.autocar.co.uk/sites/autocar.co.uk/files/images/car-reviews/first-drives/legacy/mustang-camaro-2790.jpg" /></p>
<p>So they still drive like American muscle cars. That’s the point, really, and don’t think for a moment they aren’t fun or entertaining because of it. But the Mustang and the Camaro are really only about one thing: their wholesome V8s. Being a good chunk bigger than the Ford’s engine, the Chevrolet’s motor is more powerful, producing 447bhp and 455lb ft versus 416bhp and 391lb ft. But what’s so much more important than sheer grunt alone is character and soundtrack.</p>
<p>The Camaro’s engine is unmistakably a V8, warbling into life in a way only eight cylinders in a vee can and pulling all the way to the 6500rpm redline with a wonderfully hard-edged and off-beat rumble. The Mustang’s engine delivers much the same effortless, torque-rich performance as the Camaro’s, but – criminally – it does so without a great deal of character. The soundtrack is bland by comparison, all wind rush like a hairdryer rather than being tuneful in any way, and beyond 6000rpm the engine wilts miserably.</p>
<p>Perhaps it was the Camaro’s optional sports exhaust that made the difference, and perhaps an uprated set of pipes would be all it’d take to enliven the Mustang. Whatever, the Chevrolet’s more characterful V8 counts for so much in a type of car that trades entirely on the strength of its character.</p>
<p><img alt="" src="https://www.autocar.co.uk/sites/autocar.co.uk/files/images/car-reviews/first-drives/legacy/mustang-camaro-2801.jpg" /></p>
<p>But here’s a quandary: does the Camaro’s more seductive engine outweigh the inconvenience of driving a left-hand-drive car? Maybe the novelty of its roaring soundtrack and ferocious top-end would diminish with every unsighted junction, every dicey overtake and every out-of-reach ticket machine if you used the car every day. But if you kept the Camaro as a weekend plaything, sitting over on the wrong side might even be part of its charm.</p>
<p>The <a href="https://www.autocar.co.uk/car-reviews/ford">Ford</a> certainly isn’t without its appeal, but there is more to enjoy about the Chevy. And although there are plenty of European coupés much better suited to UK roads, the Camaro proves once and for all that for soundtrack, drama and good ol’ boneheaded giggles, there’s still no replacement for displacement.             </div>
          </div>
                      <div class="sidebar-third col-right">
              <div class="block block-autocar-ads-mpu-flexible3 even" >
  
      
  
  <div class="ad--wrapper   ad--sticky"><div class="ad--slot" data-slotId="gpt_7294_mpu_flexible3" data-name="mpu_flexible3" data-order="4"></div>
</div>

  
  </div>
<div class="block block-autocar-ads-mpu3 odd" >
  
      
  
  <div class="ad--title">Advertisement</div>
<div class="ad--wrapper ad--slider "><div class="ad--slot" data-slotId="gpt_7294_mpu3" data-name="mpu3" data-order="10"></div>
</div>

  
  </div>
            </div>
                </div>
                  <div class="mid-content-region">
          <div class="block block-autocar-ads-masthead3 odd" >
  
      
  
  <div class="ad--wrapper  "><div class="ad--slot" data-slotId="gpt_7294_masthead3" data-name="masthead3" data-order="10"></div>
</div>

  
  </div>
        </div>
            <div class="article-section" data-sticky-container>
          <div class="col-center">
            <div class="lower-content-region">
              <div><div><div><div><div>
<p><strong>THE RESULTS</strong></p>
<p><strong>1st </strong>- With a more characterful engine and a higher-rent cabin than the Mustang, the Camaro is our muscle car of choice. </p>
<p><strong>2nd</strong> - Fun to drive and great to look at, but the cabin feels cheap and the engine lacks the Camaro V8’s drama and soundtrack. </p>
<p><img alt="" src="https://www.autocar.co.uk/sites/autocar.co.uk/files/images/car-reviews/first-drives/legacy/mustang-camaro-2771.jpg" /></p>
<p>This article was originally published on 28 January 2018. We're revisiting some of Autocar's most popular features to provide entertaining content in these difficult times. </p>
<p><strong>A great American rivalry:</strong></p>
<p>In the car world, rivalries don’t get much more bitter than Ford versus Chevrolet. The two automotive giants have been at war for decades, most notably in the pick-up truck and muscle car sectors. The latter conflict has waged since 1966, when Chevrolet first introduced the Camaro as its response to Ford’s genre-defining Mustang.</p>
<p>In the battle for sales, the Blue Oval has more often than not had its nose in front. As of 2014, the Mustang had outsold the Camaro in 31 of the 41 years that both cars had been on sale. In 2017, Ford sold 81,866 Mustangs in the US compared with Chevrolet’s 67,940 Camaros.</p>
<p>But the Mustang versus Camaro conflict is about so much more than just sales figures. It’s a rivalry that’s so deeply ingrained in US popular culture that, for most people, it would be unthinkable to change allegiance from one to another, just as an English football fan would never dream of switching his support from Liverpool to Manchester United.</p>
<p>Perhaps Hollywood can settle the rivalry once and for all. Arguably the Camaro’s most famous movie appearance was as Bumblebee in the Transformers series. The Mustang’s star turn? As Steve McQueen’s ride in Bullitt, of course. It doesn’t get any cooler than that...</p>
<p><strong>Read more </strong></p>
<p><strong><a href="/slideshow/mustang-all-wild-and-wonderful-offshoots">Mustang: all the wild and wonderful offshoots​</a></strong></p>
<p><strong><a href="/slideshow/mustang-all-wild-and-wonderful-offshoots">F</a></strong><a href="/car-review/ford/mustang-bullitt"><strong>ord Mustang Bullitt review</strong></a></p>
<p><a href="/car-news/industry/uk-sales-chevrolet-corvette-and-camaro-end-august"><strong>UK sales of Chevrolet Corvette and Camaro end</strong></a></p>
<p><span class="wysiwyg-embed"></p>
<iframe allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen="" frameborder="0" height="315" src="https://www.youtube.com/embed/Vzu9yBVN9Hw" width="560"></iframe><p></span></p>
</div>
</p></div></div></div>
  
  </div>
<div class="block block-autocar-newsletter-autocar-newsletter-signup-form even" >
  
      
  
  <div id="signup-replace" class="signup-block">
  <div class="rectangle">
    <div class="signup-form">
            <div class="are-you-as-passionate"><span>Are you as passionate about cars as we are? Get all the best car news, reviews and opinion direct to your inbox.</span></div><div class="subscribe-to-the-aut"><span class=""> Subscribe to the Autocar newsletter now.</span></div><form action="/car-news/features/ford-mustang-versus-chevrolet-camaro-muscle-car-twin-test" method="post" id="newsletter-signup-form" accept-charset="UTF-8"><div><div id="edit-wrapper" class="form-wrapper"><div class="form-item form-type-textfield form-item-email">
 <input placeholder="Insert email" type="text" id="edit-email" name="email" value="" size="128" maxlength="128" class="form-text" /> <span class="field-suffix"><div class="signup-errors"></div></span>
</div>
<input type="submit" id="edit-submit" name="op" value="Submit" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-2jP18STyIA3MzcBjlKnRwS2lz5sp1zfEAwRlLFbsHbw" />
<input type="hidden" name="form_id" value="newsletter_signup_form" />
</div></form>
          <div class="signup-notice haymarket-media-group">Haymarket Media Group, publishers of Autocar takes your privacy seriously. You can unsubscribe at any time using the unsubscribe mechanism on any email you receive from us. We will use your information to ensure you receive messages that are relevant to you. To learn more about how we use the information you provide to us please see our <a href="https://www.haymarket.com/PrivacyPolicy.aspx" target="_blank">Full Privacy Notice</a>.</div>    </div>
  </div>
</div>

  
  </div>
<div class="block block-outbrain-integration-outbrain-integration-external odd" >
  
      
  
  <div class="OUTBRAIN" data-src="https://www.autocar.co.uk/car-news/features/ford-mustang-versus-chevrolet-camaro-muscle-car-twin-test" data-widget-id="SB_2" data-ob-template="managementtoday"> </div>

  
  </div>
<div class="block block-outbrain-integration-outbrain-integration-internal even" >
  
      
  
  <div class="OUTBRAIN" data-src="https://www.autocar.co.uk/car-news/features/ford-mustang-versus-chevrolet-camaro-muscle-car-twin-test" data-widget-id="VR_1" data-ob-template="managementtoday"> </div>

  
  </div>
            </div>
          </div>
                      <div class="sidebar-third col-right">
              <div class="block block-autocar-ads-mpu-flexible3 even" >
  
      
  
  <div class="ad--wrapper   ad--sticky"><div class="ad--slot" data-slotId="gpt_7294_mpu_flexible3" data-name="mpu_flexible3" data-order="4"></div>
</div>

  
  </div>
<div class="block block-autocar-ads-mpu3 odd" >
  
      
  
  <div class="ad--title">Advertisement</div>
<div class="ad--wrapper ad--slider "><div class="ad--slot" data-slotId="gpt_7294_mpu3" data-name="mpu3" data-order="10"></div>
</div>

  
  </div>
            </div>
                </div>
      
  <div class="col-center">
          <div class="content-bottom">
        <div class="block block-autocar-comments odd" >
  
      
  
  <div id="comments-wrapper">
  <div id="comments-count-wrapper">
    <div class="block block-nodecomment-count even" >
  
        <h2 class="block-title">Join the debate</h2>
    
  
  <div class="comment-count clearfix">
  				<div class="label">
  				  <div class="inner">Comments</div>
  				</div>
  				<div class="count">
  				  <div class="inner">15</div>
  				</div>
  		  </div>
  
  </div>
  </div>
  <div class="comment-box comments-form" id="comments">
    <div class="comments-box-inner"><div class="block block-node-comments odd" >
  
      
  
  <a id="comment-233534"></a>
<div  class="comment first odd">
  <div class="comment-content">
    <div class="user">
            <p class="username"><a href="/users/5wheels" title="View user profile." class="username">5wheels</a></p>
    </div>

    <div class="content">
              <h3>
          <a href="/comment/233534#comment-233534" class="permalink" rel="bookmark">below 500BHP ??</a>        </h3>
            <div class="meta">
        <div class="permalink clearfix">
                  </div>
        <span class="date">
          28 January 2018        </span>
      </div>


      <div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><div>
<p>These engines on both cars can be remapped and tweeked to give in excess of 600 NHP which makes them much more interesting. Yes both are crap but fun crap. Interiors even on the Camero (my choice of the two) is still poor (comparing to a simple Audi coupe) - but what lets them both down is the stering damping and suspension. Give a Camero to Lotus for a couple of weeks and out will come a serious drivers car and worth the 1k or so it would cost. On design - Camero by a mile, in stinking yellow and a slightly larger exhast system and that would be a real car and at a very affordable price</p>
</div>
</div></div></div>    </div>
      
              <div class="links">
          <ul class="links inline"><li class="comment_forbidden first last"><span><a href="/user/login?destination=node/85349%23comment-form">Log in</a> or <a href="/user/register?destination=node/85349%23comment-form">register</a> to post comments</span></li>
</ul>        </div>
        </div>
</div><a id="comment-233536"></a>
<div  class="comment even">
  <div class="comment-content">
    <div class="user">
            <p class="username"><a href="/users/peter-cavellini" title="View user profile." class="username">Peter Cavellini</a></p>
    </div>

    <div class="content">
              <h3>
          <a href="/comment/233536#comment-233536" class="permalink" rel="bookmark">Too big too wide......</a>        </h3>
            <div class="meta">
        <div class="permalink clearfix">
                  </div>
        <span class="date">
          28 January 2018        </span>
      </div>


      <div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><div>
<p>Nice as the sound drive even, for Uk Roads they occupy too much Road space, the Yanks have never produced a medium sized Car that has been a success other than in the USA....!</p>
</div>
</div></div></div>    </div>
      
              <div class="links">
          <ul class="links inline"><li class="comment_forbidden first last"><span><a href="/user/login?destination=node/85349%23comment-form">Log in</a> or <a href="/user/register?destination=node/85349%23comment-form">register</a> to post comments</span></li>
</ul>        </div>
        </div>
</div>
<div class="indented"><a id="comment-233538"></a>
<div  class="comment odd">
  <div class="comment-content">
    <div class="user">
            <p class="username"><a href="/users/cheltenhamshire" title="View user profile." class="username">Cheltenhamshire</a></p>
    </div>

    <div class="content">
              <h3>
          <a href="/comment/233538#comment-233538" class="permalink" rel="bookmark">Peter Cavellini wrote: </a>        </h3>
            <div class="meta">
        <div class="permalink clearfix">
                  </div>
        <span class="date">
          28 January 2018        </span>
      </div>


      <div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><div>
<blockquote class="quote-msg quote-nest-1 odd"><div class="quote-author"><em class="placeholder">Peter Cavellini</em> wrote: </div>
<p>Nice as the sound drive even, for Uk Roads they occupy too much Road space, the Yanks have never produced a medium sized Car that has been a success other than in the USA....!</p>
</p>
</blockquote>
<p>And yet they only slighty longer and a fair bit narrower than a Merc GT or slighty longer and wider than an Audi A5.</p>
<p>The latter particularly never panned as too big for the UK.  The 1970's called and wants its stereotype back.</p>
<p> </p>
<p>I presume you think Lancia's rust etc.</p>
</div>
</div></div></div>    </div>
      
              <div class="links">
          <ul class="links inline"><li class="comment_forbidden first last"><span><a href="/user/login?destination=node/85349%23comment-form">Log in</a> or <a href="/user/register?destination=node/85349%23comment-form">register</a> to post comments</span></li>
</ul>        </div>
        </div>
</div>
<div class="indented"><a id="comment-233541"></a>
<div  class="comment even">
  <div class="comment-content">
    <div class="user">
            <p class="username"><a href="/users/peter-cavellini" title="View user profile." class="username">Peter Cavellini</a></p>
    </div>

    <div class="content">
              <h3>
          <a href="/comment/233541#comment-233541" class="permalink" rel="bookmark">Cheltenhamshire wrote: </a>        </h3>
            <div class="meta">
        <div class="permalink clearfix">
                  </div>
        <span class="date">
          28 January 2018        </span>
      </div>


      <div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><div>
<blockquote class="quote-msg quote-nest-1 odd"><div class="quote-author"><em class="placeholder">Cheltenhamshire</em> wrote: </div>
</p>
<blockquote class="quote-msg quote-nest-2 even"><div class="quote-author"><em class="placeholder">Peter Cavellini</em> wrote: </div>
<p>Nice as the sound drive even, for Uk Roads they occupy too much Road space, the Yanks have never produced a medium sized Car that has been a success other than in the USA....!</p>
</p>
</blockquote>
<p>And yet they only slighty longer and a fair bit narrower than a Merc GT or slighty longer and wider than an Audi A5.</p>
<p>The latter particularly never panned as too big for the UK.  The 1970's called and wants its stereotype back.</p>
<p> </p>
<p>I presume you think Lancia's rust etc.</p>
</p>
</blockquote>
<p>We clambered for decades to get the Mustang in RHD,and yet, when it did not a lot were bought or at least where I live I have seen only two or three?, maybe there’s more in the Cities I guess?</div>
</div></div></div>    </div>
      
              <div class="links">
          <ul class="links inline"><li class="comment_forbidden first last"><span><a href="/user/login?destination=node/85349%23comment-form">Log in</a> or <a href="/user/register?destination=node/85349%23comment-form">register</a> to post comments</span></li>
</ul>        </div>
        </div>
</div>
<div class="indented"><a id="comment-233553"></a>
<div  class="comment odd">
  <div class="comment-content">
    <div class="user">
            <p class="username"><a href="/users/289" title="View user profile." class="username">289</a></p>
    </div>

    <div class="content">
              <h3>
          <a href="/comment/233553#comment-233553" class="permalink" rel="bookmark">@ Peter Cavellini</a>        </h3>
            <div class="meta">
        <div class="permalink clearfix">
                  </div>
        <span class="date">
          28 January 2018        </span>
      </div>


      <div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><div>
<p>....they are a common site in Hampshire and Surrey....Mustangs everywhere- usually the full-fat example (thank god).</p>
</div>
</div></div></div>    </div>
      
              <div class="links">
          <ul class="links inline"><li class="comment_forbidden first last"><span><a href="/user/login?destination=node/85349%23comment-form">Log in</a> or <a href="/user/register?destination=node/85349%23comment-form">register</a> to post comments</span></li>
</ul>        </div>
        </div>
</div></div></div></div><a id="comment-233539"></a>
<div  class="comment even">
  <div class="comment-content">
    <div class="user">
            <p class="username"><a href="/users/muchado" title="View user profile." class="username">Muchado</a></p>
    </div>

    <div class="content">
              <h3>
          <a href="/comment/233539#comment-233539" class="permalink" rel="bookmark">Camaro?</a>        </h3>
            <div class="meta">
        <div class="permalink clearfix">
                  </div>
        <span class="date">
          28 January 2018        </span>
      </div>


      <div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><div>
<p>Hi. Since when did the Camero, become a Camaro?</p>
</div>
</div></div></div>    </div>
      
              <div class="links">
          <ul class="links inline"><li class="comment_forbidden first last"><span><a href="/user/login?destination=node/85349%23comment-form">Log in</a> or <a href="/user/register?destination=node/85349%23comment-form">register</a> to post comments</span></li>
</ul>        </div>
        </div>
</div>
<div class="indented"><a id="comment-233540"></a>
<div  class="comment odd">
  <div class="comment-content">
    <div class="user">
            <p class="username"><a href="/users/phinehas" title="View user profile." class="username">Phinehas</a></p>
    </div>

    <div class="content">
              <h3>
          <a href="/comment/233540#comment-233540" class="permalink" rel="bookmark">Muchado wrote: </a>        </h3>
            <div class="meta">
        <div class="permalink clearfix">
                  </div>
        <span class="date">
          28 January 2018        </span>
      </div>


      <div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><div>
<blockquote class="quote-msg quote-nest-1 odd"><div class="quote-author"><em class="placeholder">Muchado</em> wrote: </div>
<p>Hi. Since when did the Camero, become a Camaro?</p>
</p>
</blockquote>
<p>Since 29th September 1966</p>
</div>
</div></div></div>    </div>
      
              <div class="links">
          <ul class="links inline"><li class="comment_forbidden first last"><span><a href="/user/login?destination=node/85349%23comment-form">Log in</a> or <a href="/user/register?destination=node/85349%23comment-form">register</a> to post comments</span></li>
</ul>        </div>
        </div>
</div>
<div class="indented"><a id="comment-233546"></a>
<div  class="comment even">
  <div class="comment-content">
    <div class="user">
            <p class="username"><a href="/users/cheltenhamshire" title="View user profile." class="username">Cheltenhamshire</a></p>
    </div>

    <div class="content">
              <h3>
          <a href="/comment/233546#comment-233546" class="permalink" rel="bookmark">Phinehas wrote: </a>        </h3>
            <div class="meta">
        <div class="permalink clearfix">
                  </div>
        <span class="date">
          28 January 2018        </span>
      </div>


      <div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><div>
<blockquote class="quote-msg quote-nest-1 odd"><div class="quote-author"><em class="placeholder">Phinehas</em> wrote: </div>
</p>
<blockquote class="quote-msg quote-nest-2 even"><div class="quote-author"><em class="placeholder">Muchado</em> wrote: </div>
<p>Hi. Since when did the Camero, become a Camaro?</p>
</p>
</blockquote>
<p>Since 29th September 1966</p>
</p>
</blockquote>
<p>When has it ever been s Camero?  The car is calked a Camaro.  It even has a badge to tell you.</p>
</div>
</div></div></div>    </div>
      
              <div class="links">
          <ul class="links inline"><li class="comment_forbidden first last"><span><a href="/user/login?destination=node/85349%23comment-form">Log in</a> or <a href="/user/register?destination=node/85349%23comment-form">register</a> to post comments</span></li>
</ul>        </div>
        </div>
</div>
<div class="indented"><a id="comment-233547"></a>
<div  class="comment odd">
  <div class="comment-content">
    <div class="user">
            <p class="username"><a href="/users/cheltenhamshire" title="View user profile." class="username">Cheltenhamshire</a></p>
    </div>

    <div class="content">
              <h3>
          <a href="/comment/233547#comment-233547" class="permalink" rel="bookmark">Cheltenhamshire wrote: </a>        </h3>
            <div class="meta">
        <div class="permalink clearfix">
                  </div>
        <span class="date">
          28 January 2018        </span>
      </div>


      <div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><div>
<blockquote class="quote-msg quote-nest-1 odd"><div class="quote-author"><em class="placeholder">Cheltenhamshire</em> wrote: </div>
</p>
<blockquote class="quote-msg quote-nest-2 even"><div class="quote-author"><em class="placeholder">Phinehas</em> wrote: </div>
</p>
<blockquote class="quote-msg quote-nest-3 odd"><div class="quote-author"><em class="placeholder">Muchado</em> wrote: </div>
<p>Hi. Since when did the Camero, become a Camaro?</p>
</p>
</blockquote>
<p>Since 29th September 1966</p>
</p>
</blockquote>
<p>When has it ever been called a Camero?  The car is called a Camaro.  It even has a badge to tell you.</p>
</p>
</blockquote>
</div>
</div></div></div>    </div>
      
              <div class="links">
          <ul class="links inline"><li class="comment_forbidden first last"><span><a href="/user/login?destination=node/85349%23comment-form">Log in</a> or <a href="/user/register?destination=node/85349%23comment-form">register</a> to post comments</span></li>
</ul>        </div>
        </div>
</div></div></div><a id="comment-233548"></a>
<div  class="comment even">
  <div class="comment-content">
    <div class="user">
            <p class="username"><a href="/users/bob-cholmondeley" title="View user profile." class="username">Bob Cholmondeley</a></p>
    </div>

    <div class="content">
              <h3>
          <a href="/comment/233548#comment-233548" class="permalink" rel="bookmark">Muchado wrote: </a>        </h3>
            <div class="meta">
        <div class="permalink clearfix">
                  </div>
        <span class="date">
          28 January 2018        </span>
      </div>


      <div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><div>
<blockquote class="quote-msg quote-nest-1 odd"><div class="quote-author"><em class="placeholder">Muchado</em> wrote: </div>
<p>Hi. Since when did the Camero, become a Camaro?</p>
</p>
</blockquote>
<p> </p>
<p>Look at the nameplate badge in this Autocar article: <a href="https://www.autocar.co.uk/car-review/chevrolet/camaro">https://www.autocar.co.uk/car-review/chevrolet/camaro</a></p>
</div>
</div></div></div>    </div>
      
              <div class="links">
          <ul class="links inline"><li class="comment_forbidden first last"><span><a href="/user/login?destination=node/85349%23comment-form">Log in</a> or <a href="/user/register?destination=node/85349%23comment-form">register</a> to post comments</span></li>
</ul>        </div>
        </div>
</div></div><h2 class="element-invisible">Pages</h2><div class="item-list"><ul class="pager"><li class="pager-current first"><span>1</span></li>
<li class="pager-item"><a title="Go to page 2" href="/car-news/features/ford-mustang-versus-chevrolet-camaro-muscle-car-twin-test?page=1">2</a></li>
<li class="pager-next"><a href="/car-news/features/ford-mustang-versus-chevrolet-camaro-muscle-car-twin-test?page=1">next</a></li>
<li class="pager-last last"><a href="/car-news/features/ford-mustang-versus-chevrolet-camaro-muscle-car-twin-test?page=1">last</a></li>
</ul></div>
  
  </div>

  <div class="box"  >

    
          <h3>Add your comment</h3>    
    
          <div class="content"><a href="/user/login?destination=node/85349%23comment-form">Log in</a> or <a href="/user/register?destination=node/85349%23comment-form">register</a> to post comments</div>    
    
    
  </div>
</div>  </div>
</div>

  
  </div>
      </div>
      </div>
  <div class="col-right col-right-mobile">
          <div class="block block-mobile-sitewide-sidebar-type-3 odd" >
  
      
  
  
  <div class="car-finder"  >

    
          <h3>Find an Autocar car review</h3>    
    
          <form action="/car-news/technology/under-skin-how-porsche-revived-flat-six-engines-718" method="get" id="car-finder" accept-charset="UTF-8"><div><div class="form-item form-type-select form-item-make">
 <select id="car-finder-make-chooser" name="make" class="form-select"><option value="0" selected="selected">Choose a make</option><option value="1286">Abarth</option><option value="2104">AC Schnitzer</option><option value="2112">Aiways</option><option value="1250">Allard</option><option value="90">Alfa Romeo</option><option value="91">Alpina</option><option value="1502">Alpine</option><option value="92">Ariel</option><option value="94">Ascari</option><option value="95">Aston Martin</option><option value="93">Audi</option><option value="97">BAC</option><option value="96">Bentley</option><option value="98">BMW</option><option value="1758">Borgward</option><option value="99">Bowler</option><option value="100">Bugatti</option><option value="1149">BYD</option><option value="1776">Byton</option><option value="101">Cadillac</option><option value="102">Caparo</option><option value="103">Caterham</option><option value="1719">Changan Auto</option><option value="104">Chevrolet</option><option value="105">Chrysler</option><option value="106">Citroen</option><option value="1916">Cupra</option><option value="1965">De Tomaso</option><option value="108">Dacia</option><option value="1823">Dallara</option><option value="1160">David Brown</option><option value="109">Dodge</option><option value="1275">DS</option><option value="2042">Dyson</option><option value="1158">Eagle</option><option value="1066">Elemental</option><option value="110">Eterniti</option><option value="111">Ferrari</option><option value="112">Fiat</option><option value="113">Fisker</option><option value="114">Ford</option><option value="116">Great Wall</option><option value="1166">Geely</option><option value="115">Ginetta</option><option value="117">Gumpert</option><option value="1309">Hennessey</option><option value="1956">Hispano Suiza</option><option value="118">Honda</option><option value="1152">Hongqi</option><option value="119">Hyundai</option><option value="2194">Ineos</option><option value="1961">Ineos Automotive</option><option value="120">Infiniti</option><option value="1259">Isuzu</option><option value="1144">ItalDesign</option><option value="1947">JAC</option><option value="121">Jaguar</option><option value="2168">Jannarelly</option><option value="2151">JCB</option><option value="122">Jeep</option><option value="1715">JIA</option><option value="1255">Ken Okuyama</option><option value="123">Kia</option><option value="124">Koenigsegg</option><option value="125">KTM</option><option value="126">Lada</option><option value="127">Lamborghini</option><option value="1302">Lancia</option><option value="128">Land Rover</option><option value="129">Lexus</option><option value="1739">Lincoln</option><option value="130">Lotus</option><option value="1765">Lynk &amp; Co</option><option value="1373">Mahindra</option><option value="131">Marcos</option><option value="132">Maserati</option><option value="133">Maybach</option><option value="134">Mazda</option><option value="135">McLaren</option><option value="923">Mercedes-AMG</option><option value="136">Mercedes-Benz</option><option value="1167">Mercedes-Maybach</option><option value="137">MG Motor</option><option value="139">Mini</option><option value="138">Mia</option><option value="140">Mitsubishi</option><option value="141">Morgan</option><option value="1840">MS-RT</option><option value="142">Murray</option><option value="1487">NextEV</option><option value="1934">Nio</option><option value="143">Nissan</option><option value="144">Noble</option><option value="1808">Oldsmobile</option><option value="1231">Opel</option><option value="145">Pagani</option><option value="146">Perodua</option><option value="147">Peugeot</option><option value="1816">Pininfarina</option><option value="2071">Polestar</option><option value="148">Porsche</option><option value="149">Proton</option><option value="150">Qoros</option><option value="151">Radical</option><option value="1919">Ram</option><option value="152">Renault</option><option value="1813">Rimac</option><option value="1381">Riversimple</option><option value="1142">Roewe</option><option value="153">Rolls-Royce</option><option value="1803">Rover</option><option value="154">Saab</option><option value="155">Seat</option><option value="1147">Senova</option><option value="1305">Shelby</option><option value="1709">Sin</option><option value="156">Skoda</option><option value="157">Smart</option><option value="158">Spyker</option><option value="159">SRT</option><option value="160">Ssangyong</option><option value="161">SSC</option><option value="162">Subaru</option><option value="163">Suzuki</option><option value="164">Tata</option><option value="165">Tesla</option><option value="1239">Tiger</option><option value="166">Toniq</option><option value="167">Toyota</option><option value="1798">Triumph</option><option value="168">Tushek</option><option value="1110">TVR</option><option value="169">Vauxhall</option><option value="891">Vencer</option><option value="170">Veritas</option><option value="171">Volkswagen</option><option value="172">Volvo</option><option value="173">Vuhl</option><option value="174">Westfield</option><option value="1761">Wey</option><option value="2142">Xpeng</option><option value="175">Zenos</option><option value="176">Zenvo</option><option value="1226">Zolfe</option><option value="1235">Zoyte</option></select>
</div>
<div class="form-item form-type-select form-item-model form-disabled">
 <select disabled="disabled" id="car-finder-model-chooser" name="model" class="form-select"><option value="0">Then a model</option></select>
</div>
<input type="submit" id="car-finder-search" name="op" value="Search" class="form-submit" /></div></form>    
    
    
  </div>

  <div class="first-drives driven-this-week view-pane"  >

    
          <h2>Driven this week</h2>    
    
          <div class="view view-fautocar-first-drives-nodes view-id-fautocar_first_drives_nodes view-display-id-panel_pane_1 view-dom-id-30f41a94a25ed0620485c0d3f56faf5b">
        
  
  
      <div class="view-content">
      <div class="item-list">    <ul>          <li class="views-row views-row-1 views-row-odd views-row-first">  
  <div class="views-field views-field-field-main-image">        <div class="field-content"><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/article_image_65/public/images/car-reviews/first-drives/legacy/1-renault-zoe-2020-uk-fd-hero-front.jpg?itok=9sneYTOh" width="65" height="43" alt="Renault Zoe 2020 UK first drive review - hero front" title="Renault Zoe 2020 UK first drive review - hero front" /></div>  </div>  
  <div class="views-field views-field-published-at-1">        <span class="field-content">25 March 2020</span>  </div>  
  <div class="views-field views-field-type">        <span class="field-content">First Drive</span>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/car-review/renault/zoe/first-drives/renault-zoe-2020-uk-review">Renault Zoe 2020 UK review</a></span>  </div>  
  <div class="views-field views-field-field-standfirst">        <div class="field-content">Modest power and range gains make for a more well-rounded EV that is no...</div>  </div></li>
          <li class="views-row views-row-2 views-row-even">  
  <div class="views-field views-field-field-main-image">        <div class="field-content"><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/article_image_65/public/images/car-reviews/first-drives/legacy/1-land-rover-defender-110-2020-fd-hero-front.jpg?itok=QkFOe1Bm" width="65" height="43" alt="Land Rover Defender 110 S 2020 first drive review - hero front" title="Land Rover Defender 110 S 2020 first drive review - hero front" /></div>  </div>  
  <div class="views-field views-field-published-at-1">        <span class="field-content">25 March 2020</span>  </div>  
  <div class="views-field views-field-type">        <span class="field-content">First Drive</span>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/car-review/land-rover/defender/first-drives/land-rover-defender-110-s-2020-review">Land Rover Defender 110 S 2020 review</a></span>  </div>  
  <div class="views-field views-field-field-standfirst">        <div class="field-content">Does the new Defender have the off-road prowess to justify its name – and how...</div>  </div></li>
          <li class="views-row views-row-3 views-row-odd views-row-last">  
  <div class="views-field views-field-field-main-image">        <div class="field-content"><img src="https://www.autocar.co.uk/sites/autocar.co.uk/files/styles/article_image_65/public/images/car-reviews/first-drives/legacy/1-ford-kuga-2020-uk-fd-hero-front.jpg?itok=sE5MvkBA" width="65" height="43" alt="Ford Kuga ST-Line PHEV 2020 UK first drive review - hero front" title="Ford Kuga ST-Line PHEV 2020 UK first drive review - hero front" /></div>  </div>  
  <div class="views-field views-field-published-at-1">        <span class="field-content">25 March 2020</span>  </div>  
  <div class="views-field views-field-type">        <span class="field-content">First Drive</span>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/car-review/ford/kuga/first-drives/ford-kuga-25-phev-st-line-2020-uk-review">Ford Kuga 2.5 PHEV ST-Line 2020 UK review</a></span>  </div>  
  <div class="views-field views-field-field-standfirst">        <div class="field-content">All-new version of Ford&#039;s best-selling SUV, driven here in plug-in...</div>  </div></li>
      </ul></div>    </div>
  
  
  
  
  
  
</div>    
    
    
  </div>

  
  </div>
      </div>

</div>
    </div>
</div><!-- end of .container -->

    <div id="footer">
      

    
    
    
          <div id="footer-wrapper">
    <div class="footer-pre">
        <div class="more-from-block">
            <h2 class="more-from">More from Autocar</h2>
        </div>
        <div class="swiper-container">
            <div class="swiper-wrapper">
                <div class="swiper-slide">
                  <div class="block block-menu-menu-top-5s even" >
  
        <h2 class="block-title">Top 10s</h2>
    
  
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/car-news/best-cars/top-10-best-family-suvs" title="" class="menu__link">The 10 best family SUVs</a></li>
<li class="menu__item is-leaf leaf"><a href="/car-news/best-cars/top-10-best-electric-cars" title="" class="menu__link">The 10 best electric cars</a></li>
<li class="menu__item is-leaf leaf"><a href="/car-news/best-cars/top-10-best-family-hatchbacks" title="" class="menu__link">The 10 best hatchbacks</a></li>
<li class="menu__item is-leaf leaf"><a href="/car-news/best-cars/top-10-best-hybrid-suvs" title="" class="menu__link">The 10 best hybrid SUVs</a></li>
<li class="menu__item is-leaf last leaf"><a href="/car-news/best-cars/top-10-best-superminis" title="" class="menu__link">The 10 best superminis</a></li>
</ul>
  
  </div>
                </div>
                <div class="swiper-slide">
                  <div class="block block-menu-menu-latest-car-reviews odd" >
  
        <h2 class="block-title">Latest car reviews</h2>
    
  
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="https://www.autocar.co.uk/car-review/seat/ibiza" title="" class="menu__link">Seat Ibiza</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.autocar.co.uk/car-review/peugeot/508" title="" class="menu__link">Peugeot 508</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.autocar.co.uk/car-review/jaguar/i-pace" title="" class="menu__link">Jaguar I-Pace</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.autocar.co.uk/car-review/skoda/kodiaq" title="" class="menu__link">Skoda Kodiaq</a></li>
<li class="menu__item is-leaf last leaf"><a href="https://www.autocar.co.uk/car-review/volvo/xc40" title="" class="menu__link">Volvo XC40</a></li>
</ul>
  
  </div>
                </div>
                <div class="swiper-slide">
                  <div class="block block-menu-menu-top-manufacturers even" >
  
        <h2 class="block-title">Top manufacturers</h2>
    
  
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="https://www.autocar.co.uk/car-reviews/peugeot" title="" class="menu__link">Peugeot</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.autocar.co.uk/car-reviews/seat" title="" class="menu__link">Seat</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.autocar.co.uk/car-reviews/volkswagen" title="" class="menu__link">Volkwagen</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.autocar.co.uk/car-reviews/ford" title="" class="menu__link">Ford</a></li>
<li class="menu__item is-leaf last leaf"><a href="https://www.autocar.co.uk/car-reviews/vauxhall" title="" class="menu__link">Vauxhall</a></li>
</ul>
  
  </div>
                </div>
            </div>
            <!-- Add Arrows -->
            <div class="swiper-button-next"></div>
            <div class="swiper-button-prev"></div>
        </div>
    </div>

    <div class="footer">
        <div class="social mobile">
          <div class="block block-autocar-footer-footer-social-icons odd" >
  
        <h2 class="block-title">Footer social icons</h2>
    
  
  <span>Follow Autocar on our social channels</span>
<ul>
    <li><a href="http://www.facebook.com/pages/Autocar/88466919022" target="_blank">
      <div class="icon icon-facebook">
        <svg viewBox="0 0 100 100">
          <use xlink:href="https://release-perf-prod-d7-autocar-co-uk.whatcardev.haymarket.com/sites/default/modules/custom/autocar_footer/images/facebook.svg#facebook"></use>
        </svg>
      </div>
    </a>
  </li>
      <li><a href="http://www.twitter.com/autocar" target="_blank">
      <div class="icon icon-twitter">
        <svg viewBox="0 0 100 100">
          <use xlink:href="https://release-perf-prod-d7-autocar-co-uk.whatcardev.haymarket.com/sites/default/modules/custom/autocar_footer/images/twitter.svg#twitter"></use>
        </svg>
      </div>
    </a>
  </li>
      <li><a href="https://www.instagram.com/autocar_official/?hl=en" target="_blank">
      <div class="icon icon-instagram">
        <svg viewBox="0 0 100 100">
          <use xlink:href="https://release-perf-prod-d7-autocar-co-uk.whatcardev.haymarket.com/sites/default/modules/custom/autocar_footer/images/instagram.svg#instagram"></use>
        </svg>
      </div>
    </a>
  </li>
      <li><a href="https://www.youtube.com/user/autocar/videos" target="_blank">
      <div class="icon icon-youtube">
        <svg viewBox="0 0 100 100">
          <use xlink:href="https://release-perf-prod-d7-autocar-co-uk.whatcardev.haymarket.com/sites/default/modules/custom/autocar_footer/images/youtube.svg#youtube"></use>
        </svg>
      </div>
    </a>
  </li>
  </ul>

  
  </div>
        </div>
                        <div class="subscribe-region desktop">
                                    <div class="col">
                        <h2 class="block-title"><a href="https://pages.haymarket.com/autocar/ACAR-Enews-full" target="_blank">Subscribe to our newsletter</a></h2>
                    </div>
                                                    <div class="col">
                        <h2 class="block-title"><a href="http://www.themagazineshop.com/Autocar" target="_blank">Subscribe to Autocar magazine</a></h2>
                    </div>
                              </div>
                  <div class="blocks">
            <div class="col">
              <div class="block block-menu-menu-quick-search even" >
  
        <h2 class="block-title">Quick search</h2>
    
  
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/car-news/best-cars" class="menu__link">Top 10s</a></li>
<li class="menu__item is-leaf leaf"><a href="/car-reviews" class="menu__link">Latest car reviews</a></li>
<li class="menu__item is-leaf leaf"><a href="/car-news" class="menu__link">Latest news</a></li>
<li class="menu__item is-leaf last leaf"><a href="/video" class="menu__link">Latest videos</a></li>
</ul>
  
  </div>
            </div>
            <div class="col">
              <div class="block block-menu-menu-we-recommend odd" >
  
        <h2 class="block-title">We recommend</h2>
    
  
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/car-news/geneva-motor-show" class="menu__link">Geneva motor show</a></li>
<li class="menu__item is-leaf leaf"><a href="http://www.whatcar.com/" class="menu__link" target="_blank">What Car?</a></li>
<li class="menu__item is-leaf leaf"><a href="http://www.whatcar.com/new-car-deals/" class="menu__link" target="_blank">New Car Deals</a></li>
<li class="menu__item is-leaf leaf"><a href="http://www.classicandsportscar.com/" class="menu__link" target="_blank">Classic and Sports Car</a></li>
<li class="menu__item is-leaf last leaf"><a href="https://www.whatcar.com/car-leasing/" class="menu__link" target="_blank">What Car? Leasing</a></li>
</ul>
  
  </div>
            </div>
            <div class="col">
              <div class="block block-menu-menu-legal-bits even" >
  
        <h2 class="block-title">Legal bits</h2>
    
  
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="http://www.haymarket.com/TermsAndConditions.aspx" class="menu__link" target="_blank">Terms and conditions</a></li>
<li class="menu__item is-leaf leaf"><a href="http://www.haymarket.com/CookiePolicy.aspx" class="menu__link" target="_blank">Cookie policy</a></li>
<li class="menu__item is-leaf leaf"><a href="http://www.haymarket.com/PrivacyPolicy.aspx" class="menu__link" target="_blank">Privacy policy</a></li>
<li class="menu__item is-leaf last leaf"><a href="http://complaints.haymarket.com/" class="menu__link" target="_blank">Complaints</a></li>
</ul>
  
  </div>
            </div>
            <div class="col">
              <div class="block block-menu-menu-about-autocar odd" >
  
        <h2 class="block-title">About Autocar</h2>
    
  
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/misc/contact-us" class="menu__link">Get in touch</a></li>
<li class="menu__item is-leaf leaf"><a href="/rss" class="menu__link">RSS feed</a></li>
<li class="menu__item is-leaf leaf"><a href="/autocar-sitemap" class="menu__link">Sitemap</a></li>
<li class="menu__item is-leaf last leaf"><a href="/magazine" class="menu__link">Latest magazine issue</a></li>
</ul>
  
  </div>
<div class="block block-autocar-ads-overlay2 even" >
  
      
  
  <div class="ad--wrapper  "><div class="ad--slot" data-slotId="gpt_7294_overlay2" data-name="overlay2" data-order="7"></div>
</div>

  
  </div>
<div class="block block-autocar-ads-overlay-m2 odd" >
  
      
  
  <div class="ad--wrapper  "><div class="ad--slot" data-slotId="gpt_7294_overlay-m2" data-name="overlay-m2" data-order="6"></div>
</div>

  
  </div>
            </div>
        </div>
                <div class="subscribe-region mobile">
                            <div class="col">
                    <h2 class="block-title"><a href="https://pages.haymarket.com/autocar/ACAR-Enews-full" target="_blank">Subscribe to our newsletter</a></h2>
                </div>
                                        <div class="col">
                    <h2 class="block-title"><a href="http://www.themagazineshop.com/Autocar" target="_blank">Subscribe to Autocar magazine</a></h2>
                </div>
                      </div>
          </div>
    <div class="footer-sub">
        <div class="col">
            <div class="copyright">
              <div class="block block-copyright-notice-footer-copyright-notice odd" >
  
      
  
  <a href="http://www.haymarket.com" target="_blank"><div class="haymarket-logo" style="background-image: url(https://release-perf-prod-d7-autocar-co-uk.whatcardev.haymarket.com/sites/autocar.co.uk/files/media-icons/default/logo.png)"></div></a><span>Autocar is part of <a href="https://www.haymarket.com/brands/" target="_blank">Haymarket Automotive</a>, a division of <a href="https://www.haymarket.com/" target="_blank">Haymarket Media Group</a> © Haymarket Media Group 2020</span>
  
  </div>
            </div>
        </div>
        <div class="col">
            <div class="social desktop">
              <div class="block block-autocar-footer-footer-social-icons odd" >
  
        <h2 class="block-title">Footer social icons</h2>
    
  
  <span>Follow Autocar on our social channels</span>
<ul>
    <li><a href="http://www.facebook.com/pages/Autocar/88466919022" target="_blank">
      <div class="icon icon-facebook">
        <svg viewBox="0 0 100 100">
          <use xlink:href="https://release-perf-prod-d7-autocar-co-uk.whatcardev.haymarket.com/sites/default/modules/custom/autocar_footer/images/facebook.svg#facebook"></use>
        </svg>
      </div>
    </a>
  </li>
      <li><a href="http://www.twitter.com/autocar" target="_blank">
      <div class="icon icon-twitter">
        <svg viewBox="0 0 100 100">
          <use xlink:href="https://release-perf-prod-d7-autocar-co-uk.whatcardev.haymarket.com/sites/default/modules/custom/autocar_footer/images/twitter.svg#twitter"></use>
        </svg>
      </div>
    </a>
  </li>
      <li><a href="https://www.instagram.com/autocar_official/?hl=en" target="_blank">
      <div class="icon icon-instagram">
        <svg viewBox="0 0 100 100">
          <use xlink:href="https://release-perf-prod-d7-autocar-co-uk.whatcardev.haymarket.com/sites/default/modules/custom/autocar_footer/images/instagram.svg#instagram"></use>
        </svg>
      </div>
    </a>
  </li>
      <li><a href="https://www.youtube.com/user/autocar/videos" target="_blank">
      <div class="icon icon-youtube">
        <svg viewBox="0 0 100 100">
          <use xlink:href="https://release-perf-prod-d7-autocar-co-uk.whatcardev.haymarket.com/sites/default/modules/custom/autocar_footer/images/youtube.svg#youtube"></use>
        </svg>
      </div>
    </a>
  </li>
  </ul>

  
  </div>
            </div>
        </div>
    </div>
</div>
    
    
    
    </div>
    <script src="/sites/autocar.co.uk/files/advagg_js/js__9qdG8zVMzxZcrnq0S4_DFDSfq5Z0R4E_6XyWYjS892I__jLOLUT4cYlflwS8poCb7je8mK4rAvw3J_cFLdyBm2wo__1motoMhogn4-LmFTOSQe52-ueFiJ-892YwZHVY35O4I.js"></script>
<script>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</script>
<script>Drupal.autocarAds.gptSiteId = "8527";
Drupal.autocarAds.gptSlotId = "8527/autocar/news/results/ford/mustang";
Drupal.autocarAds.amazonId = "3110";
Drupal.autocarAds.targeting = [["site","live"],["p_manu","ford"],["p_model","mustang"],["p_multiple","false"],["p_cat","sports"],["c_title","fordmustangversuschevroletcamaromusclecartwintest"],["c_id","85349"],["n_sec1","autocar"],["n_sec2","news"],["n_sec3","results"],["n_sec4","ford"],["n_sec5","mustang"]];
Drupal.autocarAds.pageDNA = {"DNA_content_authors":"danprosser","DNA_content_has_video":"","DNA_content_has_gallery":"false","DNA_content_has_poll":"","DNA_content_id":"85349","DNA_content_language":"en","DNA_content_page_of":"","DNA_content_rating_max":"10","DNA_content_rating_score":"","DNA_content_title":"fordmustangversuschevroletcamaromusclecartwintest","DNA_content_type":"news","DNA_content_landing":"","DNA_content_subtype":"","DNA_content_publish_date":"20200326","DNA_content_update_date":"20200326","DNA_content_publish_time":"1100","DNA_content_update_time":"1101","DNA_content_taxonomy_group1":"","DNA_content_taxonomy_group2":"","DNA_content_taxonomy_group3":"","DNA_content_taxonomy_group4":"","DNA_content_word_count":"1814","DNA_content_pagetype":"","DNA_content_r_type":"","DNA_navigation_locale":"engb","DNA_navigation_site_domain":"www.autocar.co.uk","DNA_navigation_site_name":"autocar","DNA_navigation_section_child1":"autocar","DNA_navigation_section_child2":"news","DNA_navigation_section_child3":"results","DNA_navigation_section_child4":"ford","DNA_navigation_section_child5":"mustang","DNA_search_searchphrase":"","DNA_product_id":"","DNA_product_manufacturer":"ford","DNA_product_model":"mustang","DNA_product_category":"sports","DNA_product_sub_category1":"","DNA_product_product_edition":"","DNA_product_style":"","DNA_product_size":"","DNA_product_condition":"","DNA_product_price":"","DNA_product_price_band":"","DNA_product_target_price":"","DNA_product_price_currency":"","DNA_product_offer_price":"","DNA_product_min_price":"","DNA_product_max_price":"","DNA_product_version":"","DNA_product_colour":"","DNA_product_dealer":"","DNA_product_dealer_id":"","DNA_product_dealer_group":"","DNA_product_features":"","DNA_product_location":"","DNA_product_green_band":"","DNA_adzone_2":"news","DNA_adzone_3":"results","DNA_adzone_4":"ford","DNA_adzone_5":"mustang","DNA_multiple":"false","DNA_product_model_trimmed":"mustang","DNA_product_make_and_model":"Ford mustang"};
Drupal.autocarAds.debugPageDNA = false;</script>
  </div>
</body>
</html>
